UR22C not recognized by Cubase Elements 11

My UR22C suddenly stopped being recognized by Cubase Elements 11.
I’ve already tried to update both driver and firmware. Still nothing.
I am using Windows 10 and the OS seems to have no issues recognizing the audio interface.
On Cubase, I only see “Generic low latency ASIO driver”.

Anything else I could try?

What audio interface do you have and what driver is coming up when you go studio-studio setup-vst audio?

I have UR 22 C as audio interface, but the only driver which is coming up is the Generic Low Latency ASIO Driver. When it was working, there used to be a second Yamaha driver coming up if I recall correctly the name of it.

I have the same interface and version of Cubase and apart from the driver dropping out occasionally it is very reliable. It should be Yamaha ASIO driver.
Is the light on on the interface when windows starts up?

Yes it does, and other stand alone VSTs, they see the interface. Only Cubase does not. I also purchased Cubase Elements 12 now, and still it does not work…

What shows up in the windows connections. Maybe something needs ticking/unticking.