UR22mkII horrible distorted high pitched noise

I got mine UR22mk2 recently just two days ago from Thomann.de and there is quite a problem.

This happens quite occasionaly, but as you can hear in the attached link below I get this really annoying distorted noise whenever there’s an audio coming out. As I said it happens OCCASIONALLY. Right now I’m listening to some music and there are no problems at all, everything works as it should be. But when the problem starts to occur, it starts with some small hardly detectable clicks and goes crazy with these distorted and pitched noises!

I’ve already tried plugging the device to a different USB slot, reinstalling the drivers a couple times, but the problem is still there…
Please, help me out :frowning:

https://soundcloud.com/daniel1896/ur22mkii-horrible-noise-online-audio-convertercom

The problem is solved. Well, kind of…
These distortion noises didn’t bother me since installing the 1.9.4 version of the driver (the noises were happening while I was running the latest 1.9.6 version). Hope this will be fixed!

Got exactly the same problem with 1.9.6 on Windows 10. Now if I only could try the 1.9.4 version of the driver but seems it’s only available for mac. :confused:

Well, I got 1.9.4 from the installation CD that was in the box

As you’re one of the few people that already have the UR22 Mk2, could you please tell me and other interested people if:

  • you have any issues with Hi-Z (guitar/bass) input clipping?
  • any issues with using the interface with USB 3.0 port?
  • low frequency hum?
  • any other issues?

I think that if Steinberg adressed even some of those, this has the potential to be the best interface in this price range, and I’m sure I’m not alone in this opinion. So it would be really helpful if you could give us that information

I got the device last week and have the same problem. Also Windows 10 64 bit.

Going back to an older driver is not option for me since I also use the UR824 on this computer. Hope there will be a fix soon or I will have to return it. :frowning:

Windows 7 64bit, having this exact same issue on my UR12 interface as well. Found a semi-fix by going into my DAW (I use reaper) and opening the ASIO settings menu, which seems to “reset” the driver or something and will clear it if it’s happening at the time, but inevitably it always comes back. It’d be nice if there was a more permanent fix as the metronome track can cause it to happen or if I’ve got any other tracks playing while recording another one and at that point you have to put up with the awful noise until you’re done the track or you end up losing a track.

I also hit this issue on a new UR22 MK2, Win7 Pro. Reverting to the 1.9.4 driver (once I managed to dig up a working DVD drive to get it off) seems OK for the usage I have tried so far; although I was slightly concerned that I had already updated the firmware to 1.02 as IIRC the firmware page indicated it needs 1.9.6.

I am unsure if anyone from support reads the forums, given the OP reported this a month ago and the driver hasn’t been pulled. But just in case, this sounds a lot like buffer corruption in the driver; it starts to happen after a random amount of time from just a few seconds to a few minutes, it can be provoked both with ASIO (regardless of the buffer size) and WASAPI playback, the same bad audio is present on both line and headphone outputs.

1.9.4 is sadly not compatible with win10 though.

@Eloraite, could you try if 1.9.4 driver fixes the problem for you?

I’m pretty sure it’s a driver problem though as i yet have to get this issue under linux. Also would be nice if someone from steinberg could acknowledge/sticky this.

So at the risk of speaking too soon, as I often do with issues like this, it does seem like reinstalling the UR12 with the 1.9.4 driver software out of the box fixed this issue, confirming your suspicions that it’s a driver issue. I’ve had audio streaming non stop the last hour with no issues, whereas before I’d have an issue within a couple minutes. Thanks for the suggestion!

Hi all,

I just received a UR22mkII about a month ago, and I have exactly the same issue using v1.9.6 and v1.02 of the firmware. I am running Windows 10.

It has been tearing my hair out and I had literally tried everything I could think of in order to fix before stumbling across this thread (thanks for all posts so far). I was just on the brink of raising a ticket with Steinberg. The laptop is a fresh install and has had all the bloat from Windows 10 stripped away (as much as possible anyway!). Being my first ever interface I initially thought it was ASIO buffer size related, or some weird performance spike causing the issue. But I couldn’t see how because the laptop has next to nothing installed on it and is highly specced (Core i7, 8gb RAM, 128gb SSD).

Given that v1.9.4 of the driver is not compatible with Windows 10 and that people are upgrading to or installing Windows 10 more frequently now, it would be useful if Steinberg can acknowledge this issue and work on a fix. The drivers with the issue (1.9.6) have been around 2 months already so i’m surprised they haven’t been pulled. I don’t want to have to return the interface if this is not a hardware issue, because apart from the driver problem it works as intended and the latency is good enough for practicing my V-Drums - I get no pops or crackles on the smallest buffer size of 64 so I can’t ask for more really.

Every time I practice on my e-kit, at some random point this distortion is guaranteed to creep in at any stage so it is very easy to replicate if more samples are required. As sg2015 says, this is regardless of buffer size, it is present on both outputs and lasts a random duration. It also happens whether loopback is switched on or off. Changing any ASIO settings to provoke a reset or stopping playing for several moments fixes the problem in the short term, but the issue always returns eventually.

Hope Steinberg can get this resolved ASAP.

In addition, has anyone tried to install v1.9.4 of the driver on Windows 10 anyway, even though it is not listed as compatible? If not, I am happy to give it a try.

Also, if the above simply doesn’t work, if anyone has a copy of v1.9.5 for Windows would they post a link, because this has Windows 10 compatibility? This would also prove which driver version the issue manifested itself in, whether that be v1.9.5 or v1.9.6.

Thanks

I have raised a support ticket regarding this issue with Steinberg, pointing them to this thread and the other thread created by Eloraite, just to make sure to make sure they are aware of this problem.

Hi,

Just wanted to post a further update to this, in case it helps Windows 10 users. I haven’t heard anything back from Steinberg yet regarding this issue, but in the meantime I uninstalled the 1.9.6 drivers and whacked 1.9.4 on there (from the disc in the box), even though it’s not technically listed as Windows 10 compatible.

It installed with absolutely no issue at all, and so far the problem hasn’t resurfaced. So for now, this is a workaround, but Steinberg need to acknowledge there is an issue with the latest drivers and provide a fix for the next release…

Nice, can confirm that the 1.9.4 driver works like a charm with windows 10. Probably my last Steinberg product though, support seems to be non-existent.

Hi all. I am searching older driver for UR12, because with 1.9.6 I am experiencing problems. With the cd the driver is 1.8.7. Is there 1.9.4 driver for windows?

I’ve got my Interface today and i have the exact same problem on Windows 10 64bit and the v1.9.6 Drivers with Firmware v1.02. High frequency distorted Audio from time to time when i’m working in my DAW or when i’m Playing Music or Gaming. :open_mouth:

Edit: A “downgrade” to v1.9.4 from Box CD works for me in 48khz 24bit with Firmware v1.02. I hope Steinberg fixed this.

Update 2: Okay, the v1.9.4 only works in the DAW, in Windows 10 (on Desktop) self there are no Sound and i can’t Play any Music. In the Device Manager there is a USB Error for the UR22 MKII Device.

Would be nice to get an official statement to that problem. This device is currently unusable for me…

Same problem here. And I cant even go back to 1.9.4 driver, because I upgraded the firmware. Sad.

Here i found older drivers: http://www.yamahaproaudio.com/global/en/downloads/firmware_software/yamaha_steinberg_usb_driver/

I assume my problems started with 1.9.6. Yesterday i put the 1.9.5.(I have UR12). I hope that will solve that occasional weird sound problem.