ur22mkii no audio

It was working this morning and then it stopped working. It started not working after I had finished listening to a track with headphones. Checked everything in the OS (Win 10) and device manager and Cubase Artist and everything seemed normal (no errors, etc.).

Looking at steinberg support I DL’ed and installed the latest firmware and driver. All installed without issues.

Still no joy.

Switched to the laptop’s realtek driver and speakers and heard audio. That tells me the UR22mkii probably bit the dust. It is attached via a usb hub but it wouldn’t work on any other port and both the usb wireless mouse and usb license key worked when plugged into the port that the UR was originally plugged into so that tells me it isn’t the hub or the port,

Before I run out and purchase a new audio interface, is there any other test or troubleshooting technique that could establish that the problem is or is not the UR hardware?


Don’t know if this is related or not but can anyone shed light on this field in the mix console stereo fader channel strip and why it is highlighted red? Sometimes it is and other times it is similar to the channel faders (blacked out).

Just wondering if I accidentally clicked on something that might have had a global effect on audio output.

So I did more troubleshooting today.

Right after I updated the UR’s firmware and driver Windows installed an update.

So first thing I did was use the restore point it created to roll back the updates.

Didn’t help.

Tried a new usb cable.

Didn’t help.

Bought a brand new ur22mkii.

Didn’t help.

Installed both the old and new ur22mkii’s on another laptop plugged directly into the laptop’s usb port (no hub).

Didn’t help.

Verified it wasn’t my audio speakers as they played audio files on both laptops with the realtek on board audio enabled.


If you change USB port you perhaps need to reinstall the software again? Dont know if that helps, could be worth a try though… I mean, every time one changes the USB port for a UR-unit the software needs to be reinstalled (the USB driver, at least)… So I’ve read elsewhere though… (I guess you’ve already read the manual for troubleshooting, errors, etc? Also, you can try googling, YouTubing, etc for help aswell). But if its fried, its fried… How old is the unit?