UR28M + big sur

Please I need one help : my UR28M after Big Sur Upgrade doesen’t work anymore ! my question is : if I buy and dowload new software CUBASE 11 could solve this problem ? drivers and software are included ? could works ? NB: I use this harware UR28M with Premiere Pro CC 2020 . thanks

No, Cubase won’t help you get your UR28M running, sorry.

so finally I have to wait one firmware upgrade on UR28M , no other solutions ?

You could roll back to the previous version of the os, right now there isn’t much confirmed support when it comes to software or hardware from manufacturers. This is often the case with mac, so most ppl hold off until all their stuff is confirmed to work on the new os.

thanks your advices , i do it .

I do not profess to be any kind of an expert but I have found a solution by instinct I guess … In big Sur, after tinkering for days , I uninstalled the driver with the tools as well as the newer usb driver on the steineurg download page … I then rebooted my Mac into Big Sur … I opened the security / privacy setting on my Mac … Then I installed the newest Yamaha usb driver download. https://download.steinberg.net/downloads_hardware/Yamaha_Steinberg_USB_Driver/Mac/2.0.4/YSUSB_V204_Mac.zip?_ga=2.151704506.2097546739.1607148545-1933961867.1607148545. Then I noted from the security page that it was being blocked … Normally this flags up a warning automatically … Not so in Big Sur … So unlock your privacy setting … Grant access … restart and … Voila !!! On your own head be it as I am no authority on such thins ok … Hope this helps . Russell :slight_smile:

Install the newest usb driver whilst keeping the security / privacy settings open … The flag that usually shows up warning that the software has been blocked in previous apple os will show … Unlock … allow to run … restart and voila !!! I tinkered … I am no authority but it worked . Russell :slight_smile:

Just update my Mac OS Big Sur to 11.5.2. My UR28M appears to by synced, but it’s not showing in the sound menu on Preferences. Also, it’s not listed in the MIDI control window. I’ve uninstall the old driver and replace it by the new 3.0.5 version, as recommended. Not working at all!! My interface was working before the 11.5.2 update ! Please help !!

I installed it and it worked all day yesterday. Today I can’t find the UR28M anymore! Tried gun_unrainn tip but no chance. Frustrating.

Here is the solution:

  1. Download the Tools for UR28M
  2. Make sure for BigSur you install the Yamaha Steinberg USB Driver V3.0.5.pkg (See Picture) - Restart your system
  3. Go to System Preferences->Security & Privacy and unlock the lock with your password.
  4. Click on Details and make sure Yamaha is check marked to allow it to operate

PS: If you just install everything from the Tools with the installer the wrong USB driver might get installed. So make sure to uninstall that one first and manual install V3.0.5