UR28M-Dedicated Windows for Cubase Series

Hi there,

got today the UR28M. Installing driver, updating firmware, all went fine. Also get sound out of it :wink: But what drives me crazy is where to find those dedicated windows for the cubase series. The manual shows screenshots of an old Cubase version, but not one of Cubase 7. For one time I was able to find this hardware window. But now I don´t find it anymore. And where please to I find/open the Input Settings Window in Cubase 7? Or is there nothing more than just to put the ur-plugs into the insert slots? Any help would be nice.



Closed Cubase, opened dspMixFx. Switched a bit around on both, hardware and the app. Opened Cubase again and there it is again “Audio Hardware Setup”. So seems to be sth like a bug. There is also now the in Mixconsole/Racks Hardware for choice.
Anyone else this problem with this its there, not there, its there Hardware option?


The dspMixFx app has no influence on Cubase. I am fairly certain your problem was caused because the ASIO driver was not selected in Cubase which could have been caused by the UR28M not being turned on when Cubase was started or being turned off and back on while Cubase was running. This is important other wise if the unit is turned on after Cubase starts, you will have to re-select it in the control panel (and possibly need to remap it in vst connections) but the hardware racks may not be visible in the mixer.
To ensure you’re set up correctly, turn the UR28M on prior to starting up Cubase.
In Cubase Device Setup go to VST Audio system and select the Yamaha Steinberg USB ASIO driver in the ASIO Driver pull down.
There will now be further choice for the Yamaha Steinberg USB ASIO under VST Audio System in the left pane. Click on this and you will be presented with all the ins and outs of the unit (most should be Active except possibly the S/PDIF ins and DAW outs). At the top of the right panel you will see Control Panel in which you can set your buffer size and sample rate.
After closing the Device Setup window, select Audio Harware setup from the Devices menu and you will see the window shown in the documentation in which you can make various HW adjustments.
Next step would be to open the VST Connections window and select or control the inputs and outputs.
Finally, in the mixer, ensure that racks are selected in the layout, that input channels are selected in channel types, and then hardware selected in Racks.
At the bottom of the hardware graphic in the rack you will see a headphone symbol and a bargraph. Clicking on either of these also opens the UR28M Hardware setup with the headphone select tab or reverb tab selected respectively.
Hope this helps.

Hi BriHar,

thanks for your detailed description and help. I did it all like that, but nevertheless I just experienced again the missing hardware setup. Looks like I was to fast after first switching on the UR28M, with starting Cubase. Save procedure seems to be, switch on the device, count to 10, pull of USB and back and than start Cubase. Only thing I don´t have in the CoreAudio Device Settings is the possibility to set the sample rate. There I only have the choice for to set the Buffer Size (Cubase 7.0.4). But this I think is just different on OS X.


Don’t know if it’ll help in your case, but FWIW, I turn on all peripheral devices including the UR28M before I even boot the computer, never had a hitch.
Perhaps it’s a Mac thing, so hopefully someone from the Mac persuasion will chime in with some useful hints for you.

I have the same problem.
It’s driving me crazy.

In one instance it is there, the next it is not.
And when it was, it crashed the program when i tried to change something in it.

Using Cubase 7.0.4 with latest firmware and drivers installed for the ur28m.

Thank you again, BriHar!

I know this is an old thread but I am getting the same issue and Steinberg support was of no help. They tried to blame it on my UR28M without even troubleshooting.

Something interesting is that it shows up in the Racks but only in the “Empty” template. If I open up any of my templates, it is nowhere to be found.

Did anyone find a solution?

Can confirm this “bug”. Hardware menu there or not. But never tracked it down what is causing it. Also the dspMixFx sometimes is just greyed out depending on used with Cubase together before or not. Also using my UR28M for the general or other apps output. Only restart helps than.

This happens to me sometimes, when I click show all in the rack view it reappears even though it was supposed to be visable with my defaults.

Perhaps it’s a USB port issue. Are you using v2 or v3 ports, are you using a hub?

I figured out why it wasn’t showing for me. Not sure if this is a bug or not. In order to see the hardware setting in the channel, it will only show up in a STEREO input. It won’t show on mono input or even on regular stereo/mono tracks. It has to be the stereo input channel. This seems a bit wack to me since I would like to have all settings on one channel. It just makes sense.

The other stupid thing is if I’m recording a vocal, I’m not recording stereo. I will record mono. That means I can’t use the reverb on it while tracking.

I Checked into this and sure enough the Hardware rack will not display. What’s more, when I start Cubase, The Audio Hardware Setup item is missing from the Devices menu - I have to go into Device setup, deselect the Yamaha ASIO driver then reselect it, and it seems to me the dspMixFx app is also no longer working correctly - I can no longer set independent out levels.

Then no sooner do I finish the above post, and the dspMixFx app seemed to crash. Then it worked again and fully functional. I closed it, started Cubase and the hardware rack was working, although the Audio Hardware Setup item is still missing from the Devices menu .
I’m going to have to keep an eye on this, perhaps something to do with Windows 10, I never had such an issue on 7.