UR28M driver issue(SOLVED)

Hi Steinberg/forum.

I have a delicate problem.Sorry for trouble with my english,I´m from Sweden.

Gear - Brand new pc I5 8GIG ram Cubase 7.1 fullversion UR28m and latest drivers everywhere included updates for UR28m

Problem - irritating noises from/through UR28M.Like an electric issue,somekind of ground problem.I don´t know the exact name for it - STATIC electricity sound maybe? It is LOUD and listening to music from any source is a pain.Though,I find my own solution without grounding UR28M anywhere.But I don´t think that is the problem…


Solution - Everytime I dissconect UR28m and reinstall drivers,it works fine.Type of a wellfare problem :slight_smile: ,anyway - very irritating when I have to reinstall the drivers everytime the computer has been turned off.But that is the only way to avoid the problem.Vice guys might say leave pc/UR28M on - well we have to think globally - spare the sources of nature :bulb: saving money is another point of view.
UR28M delivers perfect sound when it works and I just tried it in a recording - great.

I would like to have this “workaroundissue” fixed if it is possible.I´m starting to gettin´n used to it now but…

Permanent SOLUTION/driver update maybe or some tips how to fix would be appreciated.

This problem is SOLVED - I rolled back the elder Yamaha driver and it has been working perfect for more than a week now.
Best regards

Micael

There is a problem with the newest Yamaha driver. As described on the Steinberg update site: http://www.steinberg.net/en/support/downloads_hardware/downloads_ur28m.html


Important note for Windows users:

Under certain circumstances, the Yamaha Steinberg USB driver that is part of the current TOOLS for UR package may cause distortion and noise when used with non-ASIO capable software. This can be avoided by setting the ASIO buffer size to 512 or higher.
If you need to work with lower latencies than 512 samples, please uninstall the Yamaha Steinberg USB driver V1.7.2 using the Windows software control panel.
Then, please install the driver V1.6.5 which can be found below.


For me, buffer size of 512 is completely UNACCEPTABLE. I cannot be switching the buffer size every time I switch between Cubase and Windows Media Player - this is something I do constantly during mixdowns.

I followed the recommendation and rolled back the Yamaha Steinberg USB driver and the problem is solved, afaik. We’ll see if any other issues crop up :neutral_face:

Thanx man for the tip…I followed your driver suggestion and my gear has been runnin´great for over a week now.

Problem solved :smiley:

Mike