UR28M Issues & Bad Customer Support

I’ve been using the new UR28M for about 2 weeks now. From day one I’ve had problems with this unit (audio clock errors, distortion, drop outs etc). I contacted customer support (Yamaha Australia - Steinberg only allows support to distributors for certain countries) and they haven’t gotten back to me. That was over a week ago! The store where I bought it from didn’t seem to have any luck either. It seems like Steinberg’s customer support is on par with Avid, which is horrendous. I should also point out that the UR28M is made in Indonesia.

Hello DPJ,

did you contact our collegues in Australia with help of the support request form ? Did you get an Email that they have recoeved your request ?

I should also point out that the UR28M is made in Indonesia

This is also written on the box. What do you want to say with this ?



Yes, I did contact Yamaha Australia with a support request from. I also phoned them and left a message on the tech supports answering machine. Still no reply. I don’t see why I can’t just deal with Steinberg directly. If you are going to have your distributors take care of your tech support you have to have them do it properly (or at least reply to the customers!). It’s made me not want to purchase another Steinberg product again.

I was trying to say that I was surprised that it was made in Indonesia. I know it’s written on the box, that’s how I know. Most stuff imported into Australia that is made in Indonesia is usually poor quality. I thought Steinberg was German.


You are right as we have had some internal communication errors and we are very sorry for that!
But I hope that our last emails have improved the situation for you.


Terms of use, excerpt:
“we at this forum reserve the right to delete any message for any or no reason whatsoever”

Nothing improved so I returned the unit. It’s been over a month now and still no reply from Yamaha Australia. What a joke! I will never buy another Steinberg product again.

ur28m is not listed on the Yamaha web pages so it must be ‘too new’ - pity.

Wouldn’t be blaming Steinberg for that though

You DID download the latest drivers etc?