UR28M - no recording Line 3/4?

I have kind of a unique issue I’m trying to sort out. I use my UR28M for Twitch streaming primarily (girlfriend uses it for music recording). I have 2 mics in Line input 1 and 2. I recently bought a turntable which I have connected to line 3/4. It sounds great on my headphones/monitors, but the problem is I cannot record/stream it. Does Line input 3/4 not go to the PC? Obviously I have no problem pulling audio onto my stream from 1 and 2 but 3/4 seems to only be available to monitor and does not record.

Sorry if my problem is a bit unclear, I’m a hobbyist so my audio setup knowledge and lingo is pretty amateur. Basically I want to be able to stream the audio coming through line 3/4 to twitch.

I know I can pull it via loopback but my PC audio runs through the interface as well and would double back to the stream twice if I were to do that.

Bump, still looking for help on this. :frowning:

hi crake,

i also have an ur28m, maybe you need an amp between turntable and line 3+4. the output of the turntable is to low.
that’s i think. trie an emped signal, because you have input control on the normal turntable.
hope this helps


Well if Crake can monitor the signal OK I’m guessing the deck has a preamp built in or they are using a preamp of some kind.

Inputs 3/4 are available to the PC but probably it needs to be enabled in whatever software you are recording into (streaming from in this case).
I would check the forums of the broadcast software for how to mix and stream multiple inputs.

If they do not have these options you could certainly do it with something like this:


Thanks, I had been looking into this software as an alternative - was hoping I could avoid adding another level of complication but I suppose this will be my best solution for now since OBS does not seem to have the ability to pick up from these inputs! As you suggested, my deck has a preamp and the levels are not an issue at all. Thanks for the response!

Just a follow up, messed around with that program a bit and I can’t for the life of me figure out how to add the line 3/4 input to it. Looking for tutorials has not helped thus far. Any advice?