UR28M won't turn on

My UR28M does not turn on anymore.

The power button has a faded light but the device won’t turn on.

I have tried different adapters.

I was able to turn it on a couple of times after removing the adapter and putting it back again but now I am hopeless.

I suspect it is a hardware issue inside the board (a capacitor or something).

Any idea?

Usually you only need to press the power button to turn it on and press and hold for 3 seconds to turn it off.
Occasionally the device might fail to turn on and in this case, usually the problem can be remedied by unplugging the power cord for a moment and then restarting as usual.

@BriHar Yes, before I made this post, I was able to turn it on two times after removing the power cord and putting it back (I also tried different adapters but the device “decided itself” when it wants to turn on).

However, this method does not work anymore.

Did you ever solve this issue? Mine just started doing the same thing out of nowhere. I was planning to replace it anyways but I’ve only had it a few years - there’s no reason it should be dead this soon.

I had this problem, I used a trick that I would use to get my tv to turn on. I unplug it and press the power button for about 60 seconds, plug ac back and it works again.