UR44 ASIO not recognized by Cubase 8 and Melodyne on Windows 10

Hello everyone, I’ve got a problem going on and very little time to fix it (in the middle of a due project on borrowed gear). If someone can direct me to another thread that I am not finding, that would be great, but I’ve tried a bunch of things I found on here and on Google, and nothing happens.

On my Windows 10 which I updated recently, my UR44 ASIO driver has decided to stop working - Cubase 8 and Melodyne say “Device could not be opened”, but Windows runs it and there is output to speakers, however, once every 5 minutes it produces a horrible loud screech while playing audio, out of nowhere. I have managed to hook it up with Melodyne through ASIO4ALL, but it’s very glitchy, and same screeching appears every now and then for 10 seconds.

Tried different cables, reinstalling the driver/tools, CC mode on/off, but haven’t had time to try on another computer. If there is any hint on fixing this, I would appreciate the help. Thanks

Bogdan

I don’t know what the bunch of things were, but the first thing I would do is to uninstall the Yamaha Steinberg USB driver using the Windows Program and Features control panel, and then restart the computer.

Then install the latest version of the Yamaha Steinberg USB driver from this page: https://www.steinberg.net/en/support/downloads_hardware/yamaha_steinberg_usb_driver.html

This is a newer driver than the one in the UR44 tools installer.

Thank you! I will try that in that order soon