UR44 - Bug with iOS video recording

I tryed to record some electric piano sessions using my iPhone as a video recorder connectected with a USB camera connection kit and the UR44.
I can like this record the piano Line out directly into the phone.

the problem when the UR44 is plugged with the iOS device is the official iOS camera video application just start then stop immediately at the first time and create a dummy video file. then the second time I push the start button the application start the recording but hang like this. with no way to stop it and nothing is really recorded.

If I unplug the UR44 from the iPhone (or iPad) the application respond normally.
The UR44 is working fine with dedicated audio application on iOS.

Also I noticed that some time it worked fine but it’s like 1 time on 20 times try and the next time I stop the recording and restart it the same error as described previously will occur.

I tried using those config:
UR44 révision 1.0 then 2.10
iPhone iOS 7.1.1
iPad iOS 7.0.6

By the way I used an iRig Pro in the past and it was working fine (but only in mono of course)

Steinberg says it is the fault of the app developer, although I agree with you, the issue seems exclusive to the Ur44.

More info: http://www.steinberg.net/forums/viewtopic.php?f=157&t=59731

Thank you for your reply.