UR44 Inputs missing when using ASIO4ALL

Hi! I love my UR44. It’s overall a great interface. Mostly no problems, but recently, I’ve tried use my UR44 with ASIO4ALL. I’m doing this because I want to record 8 channels. Recording this Drumset into FL Studio. With the UR44, I only need two more channels, so I connected my Fast Track Pro. this works mostly perfectly except for the fact that I can only get the first two inputs from the UR44. The other 4 are not read by ASIO4ALL. I was wondering if there was some kind of fix for this or if it would be addressed in a future update? With other interfaces I’ve used (and I used a sucky EIE pro-- which I sold for the UR44 :smiling_imp: ), slaving them to ASIO4ALL worked perfectly, but I’m not getting all of the inputs and this is frustrating.
Also tried in Pro Tools and Ableton and I can’t get those inputs with ASIO4ALL for the life for me. Has this happened with any other UR or ASIO4ALL users? Please help out if anyone can.
Thanks!
only 2 inputs available on asio panel.JPG
only 2 inputs available.JPG

Ask the asio4all developer

I think this is not about ASIO4ALL developers. I’ve read some forums mentioning that UR44 has only 2 WDM compatible channels so you can only see 2 input on ASIO4ALL interface.

Has anyone been able to solve this issue? I want to use my UR44 with Roland TR8S and combine those two into ASIO4All but unfortunately I can see only 2 inputs and 2 outputs for my UR44 which is very disappointing.