UR44 MIDI in port problem

I have a problem with my UR44 MIDI IN port. When I plug my CASIO WK-3000 synthesizer (I’m using it as a MIDI Keyboard)
into MIDI IN port on UR44 and hit some notes, DAW plays random notes and some of them keep playing until I hit MIDI panic button in my DAW. I’ve checked my synthesizer by plugging into M-Audio MIDISPORT 1x1, synthesizer’s MIDI Out port is working. I’ve also checked MIDI Out on UR44 with the MIDISPORT, it is working as well. My UR44 firmware version is 2.1.1. I’ve tried to get MIDI IN work in Mac OS 10.8.5 and in Windows 7 64 bit and in different DAWs: Pro Tools 10,11 and Cubase Elements 7. But it is all the same in both OSes and DAWs in any combination. What kind of problem could it be? Should I change my Audio Interface?

I don’t fully understand what you’ve been trying already since it’s a little hard to decipher your english (no offense) but if you use the Casio synth as a MIDI-input it should be routed in your DAW to a VST softsynth.

If you however want to record native sounds from the Casio synth then you shouldn’t use a MIDI port but a Line-in.

It is routed correctly. I don’t need sounds from Casio, I need MIDI events from Casio MIDI Out port to be interpreted right. I’ll try another MIDI Keyboard with UR44.

I have exactly the same problem with a Roland VR-09 keyboard. Most of the time the DAW records no notes at all. Occasionally it will record a random note that will continue to play until I stop the recording.

The same keyboard works without problems if the MIDI is routed through a Native Instruments Komplete Audio 6 interface or just with a USB cable between the keyboard and the computer.

It seems that the Steinberg MIDI driver has a problem with certain MIDI keyboards.

@Itrul: I have absolutely no problems understanding your English. You description of the problem seems quite clear to me.

Ok, I tried my UR44 with other MIDI Keyboard - Samson Carbon 61, it works fine. I’ve also tried M-Audio Keystation Pro 88, it works as well. So it is some kind of compatibility issue, maybe voltage, MIDI protocols or something related to synthesizers.

I’m also having this problem with the Casio WK-3000. Is it possible that this will be solved or should I buy another (simple) MIDI Interface that would only be used with the WK-3000?

It works perfectly OK with my ancient Terratec Phase 88 but I really need to upgrade my setup.

I can confirm exactly the same problem with UR22C on iPad Pro 12.9” 2021 and M-Audio Keystation 88. No matter whether the interface is bus-powered or on power adapter. It works perfectly on Windows 10 (I dual boot 10 and 11 and use 10 for audio work - I have yet to test it on 11), but on iPad, no matter the app - Cubasis, Auria Pro, Dorico, Animoog Z, Sampletank, whathaveyou - it is a complete disaster.

This effectively renders the interface utterly useless to me, and I am returning it to the vendor at the end of the week, unless Steinberg provides a solution.


EDIT: oh dear, this was a woeful necrobump. Should have checked the year. Well, hit shappens.