UR44 not found on mac (most of the time)

i have seen similar threads here, but any suggested causes or solutions don’t apply here.

i have an imac, running mojave - i have studio one 3.

i have tried installing the software form the cd delivered with the UR44, as well as with latest versions of software i got from the steinberg and yanaha sites.

i think i have followed instructions carefully - i have tried the CC switch in both on and off position, i must have retried the installation 3 or 4 times. using different usb slots etc.
to no avail. the best i got was on 2 occasions (and i cannot figure out why then) when the UR44 actually did show up in my audio list, as wel as studio one’s list of preferences. that is, until i opend (i think) the ur44 software mixer. then it was gone.
and eh - on the other occasion when the UR44 was found, the ur44 mixer software was not available/found…

in fact, in 1 of those 2 instacnes, the midi interface was not recognised. the latest try resulted in both audio and midi not recognised or found.

the hardware seems to work fine. inputs are fed to the monitors, sound is great, i can adjust things using the ur44 software, but i just cannot incorporate the imacs sound, no sound to or from studio one - no itunes, nothing.

it’s a shame bacause i was hoping the steinberg would give me great sound quality as well as the flexibility to reroute some recorded sounds back to external fx and back into the interface again. but with the interface not even properly recognised or found, i haven’t gotten no where near trying this.
i am about the throw in the towel and get another interface.

can anybosy help, am i making a mistake? what can or should i do? thanks.

Hi verbos,

I experienced some similar issues recently; my UR44 didn’t show up in dspMixFx device list, and I couldn’t get direct monitoring to work (even though the UB44 shows up in my interface list in my DAW (Logic Pro X) and I was able to record and playback through the interface fine).

I recently installed Mac OS X Mojave - I read in another post that the initial version of Mojave had some bugs which caused audio interface problems - I upgraded Mojave to the latest version (and turned my UB44 off an back on), and it seems that all of my problems have been fixed.

I don’t know if this will help, but just thought I would mention it!

I’m having the same problem, recently just updated to mojave, but apparently, I couldn’t even get it to be read by mac as an output and input for my macbk, tried switching on and off both UR44 and my macbk, reconnecting the usb port and all but it still couldn’t work.

Update: I thought I had fixed the problem for good, but I was having more trouble with the UB44 earlier today - fortunately I got it to work again by following these steps:

  1. Turn off UB44
  2. Set CC-Mode to off
  3. Turn UB44 back on

After this the DSPMixFx program (and direct monitoring) work again - based on this, it could be possible that an outdated version of Mojave was not the cause of my problem