UR824 Audio Drop outs/Lag under load HELP ME!

Hey guys,

Another one of these threads I know, I have seen several of these and have tried what feels like almost everything.

Up until recently everything was working fine, upgraded my RAM and monitor suddenly I am getting audio drop outs, it seems to only happen when I am gaming and only on some games, has not happened in pro tools yet, however it does seem unstable with pro tools, crashing more than usual, sighting the problem as my Steinberg disconnecting or “having an issue”.

Seems like such an odd issue, only happens sometimes for some games and happens when there is lots of sounds going on at once, almost like its been overloaded and cannot handle it, no issues with films, youtube, netflix etc.
Feel like I had this issue in the past and was easily fixed by messing around with usb ports and settings in J-River, but never this bad and so selective in when its going to drop out, previous issues I remember were universal and happening often.

I am getting the “audio interruption due to usb error” in the USB driver controller.

32gb ram 4000mhz (running at 3400) had stability issues seems to be Asrock mobo cannot handle 4000mhz,
RTX 3080,
AMD Ryzen 7 3700X CPU
Asrock phantom gaming 4 mobo,
Aorus FV43U monitor
Steinberg UR824 Audio Interface -D08
JBL LSR 3 Series 5.1 set up.
running into JRiver media center. (problem still persists if j river is not used)
problem does not occur when running audio though my screens speakers.

Any help or something I have not considered would be awesome,
Things I have tried:

Changed all power settings in windows to performance,
Disabling CPU boost in Ryzen master,
Trying USB 2.0, 3.0 and 3.1 ports (pretty sure I have all three)
Updating every single driver on computer
Rolling back Steinberg drivers, Updating Steinberg drivers,
Rolling back nvidia gpu drivers,
Removing all audio drivers but Stenberg and J-river drivers
Troubleshooting with LatencyMon seeing if anything is lagging my system, seemed to be Nvidea or my network drivers that were causing issues however have now fixed them, according to LatencyMon. Problem still persists, although may be better?
change buffer settings in both USB driver and j-river no effect.

Please help me.

Ok, well after some testing, seems I have fixed the issue. Posting here in case anyone else has this problem.

Seems if I run my ram at speeds of anything above 3466mhz the issue is there. Strangely at 3400 the issue is there but not at 3466. Anything below 3400 is fine.

Curious to know if anyone else has this issue.