UR824 fails on Z87 chipset

Upgraded my PC to the new 4th generation Haswell i7 processor, and on this brand new super fast configuration my UR824 skips the sound every 2-3 seconds in Cubase 7, as well as in any other Windows application. Tried the UR824 on my laptop and it works flawlessly there, but it does not work on the new Haswell configuration.

Intel i7 4770
Asus Gryphon Z87
8GB DDR3 (Corsair XMS 1600Mhz)
Samsung 840 120GB SSD for system
Samsung 840 250GB SSD for samples
Hitachi 3TB HDD for storage

UR824 firmware: 1.5
UR824 driver: 1.7.3

Win 7 64 bit, optimized for background services and for best performance

Tried it on USB3 and USB2 ports, rolled back driver, tried with 1.5, but skips still occure, although time shortened, same with driver 1.6… I also found Yamaha Steinberg USB driver 1.8 on Yamaha website, and it does not solve the problem either.

Any help on this is very much appreciated!

Elsewhere on the forum (I can’t remember exactly where) there is a recent thread where it’s suggested you shouldn’t optimise anything other than Windows XP for background services - Windows 7 and Windows 8 should be optimised for programs.

I have to say that I would suspect some other reason for your problem. I have two UR824s and they play beautifully with Windows 7 and 8, and I’ve only recently changed from background services to programs. I’m running at 64 samples buffer, with a latency of about 5ms in and 6 ms out.


Some of the first Z87 motherboards had USB issues, you’ve probably got one of them, get in touch with your supplier.