UR824 Monitor Interface cubase 7

Heres my setup:

Steinberg UR824:
Input port 1, my 909 drum computer bassdrum
Output port 7-8, my monitor speakers

Devices>VSTConnections>Studio, i create a stereo monitor interface and link port 7-8.
I press F3 and open up control room and click the L to listen on my Input port 1

Now i hear my sound double (at the speed of the latency of the ur824), how can this be?
When i turn up or turn down the miliseconds latency by adjusting the buffer size i hear the difference.

  • the source sound is good
  • i can record it and play it back and no double sound , only happens when i use monitoring
  • when i use monitoring i dont use a normal stereo out just to confirm i generate no double signal.

is this solvable its bugging me for a year now

Hi There

I presume you are using the control room, and if so, do you also have the main stereo out connected in the “Outputs” tab of VST connections?. If you do, then this is probably the source of the problem, there is a preference that can be ticked to avoid this (can’t remember what it’s called, not at my main machine atm)otherwise I’ll keep thinking on it, should be easily solvable)

Best Regards


just a mono in channel, no outputs configured to keep the trouble shooting simple. The strange thing is if i put on the input channel an insert and make it run dead i hear it solo and not doubled.

Got it fixed, at audiohardware setup > settings , I checked the loopback marker.

everything working fine now !