Urgent! Dorico not saving properly

Yesterday I’ve been working on a project for many hours all day and today I wanted to continue with it, but only to find out the file was the same as two days ago, so without any of the changes I made yesterday. I had the same feeling before that changes weren’t saved, but Dorico crashed during my work, so I thought it had to do with that. But now I’m sure it didn’t save okay.
Anyway, I looked the file up in the file explorer, but the saving date was also incorrect: October 19th at 4.11 pm the file was saved, but I worked on it the last time on the 22nd of October. Digging further showed that this is the most recent version, both on my disks as in the cloud.
Maybe it’s important: I run VE Pro and send the midi from Dorico to VE Pro for playback. Unfortunately, I’m not sure if Dorico or VE Pro hung on quitting yesterday, since - and I’m sorry to say that - this happens pretty often lately.

Now I’m stuck because it’s no use to work on my project, not knowing if it will be saved correctly, throwing away many hours of work.

What’s in your Backup folder? Anything from the last couple of days?

The same: Octobre 19th

Have you tried saving some test files? IOW, make a minor edit and save. Close and reopen. etc to see if you can narrow it down?

Do you save regularly as you work? Especially after a lot of editing. I don’t know about the auto-save feature in Dorico but I generally hit Ctrl-S every time I pause to think or regroup in any program I use. If you had a crash, that might explain the loss of edits to the file.

The very first time I used a word processor, 35 years ago, I stayed up all night typing a term paper. It crashed when I tried to print. I hadn’t saved once. I’ll never make that mistake again.

There’s a possibility that the Dorico license was working correctly when Dorico was opened, but then ceased to function (or, if using the USB eLicenser the dongle was removed or dislodged). I’m not sure whether Dorico gives a warning in these circumstances, but it would explain why Dorico stopped saving.

Not yet, at first I tried to find out what went wrong and later today I had other business to attend to. I will do this tomorrow.

Yes, I save pretty often myself, plus I have set Dorico to autosave every five minutes, but also the last auto save was from four days ago.

I had no warning about eLicenser errors or other failures. It’s a complete mistery.

I had the same issue about the same time ago… only it was my girlfriend who typed her paper in without saving it once (I didn’t tell her how). When the computer froze and crashed, I ended up retyping her entire paper with her dictating. Since that time, Ctrl+S is a reflex I can’t ignore. :wink:

Yes, I created a new project from scratch, entered some notes and saved it. This went well, no problems there.

Unfortunately, with the project I am working on at the moment, this went wrong: I made some changes, saved the project and then quit Dorico. On exiting Dorico hangs and won’t fully quit. Looking in the Windows task manager, it says both VE pro and VST Audio engine don’t respond, and Dorico 3 doesn’t respond. Waiting for a while doesn’t help, the situation remains the same, so I force quit the program. Re-opening the project shows none of the changes I made were saved, despite the fact I hit Ctrl+S several times during work and before quiting I also did a manual save.
The Windows file explorer shows that the last date the project was saved, was again Octobre 19th, not the date of today, same for the autosave.

Because the new project saved well, I think I must accept that my latest project has become corrupt, which is a major problem, because it was almost finished. Maybe I have to create a new project and copy everything from the current one into that and hope it will work again as it should…

This sounds a little like the problem mentioned in another thread of the Audio Engine shutting down early and thus preventing Dorico from closing normally (and saving).

https://www.steinberg.net/forums/viewtopic.php?f=246&t=170631#p911731

Yes, I read that one, but since it was o Mac (I’m on Windows) I didn’t really dig into it

I have found a problem with Windows Explorer Quick Access which may be relevant.

Many times I’ve backed up the files I’m working on only to find that Windows Explorer hasn’t updated the Quick Access screen and the time stamps are all wrong! If you’re not careful you can look at these and think that Dorico hasn’t saved you day’s work. However, if you access the proper Explorer window you’ll find your files have been saved with the correct time stamps and all is ok.

I ran into this problem for a long time before I figured it out. It’s a Win10 problem that affects all the files you save.
Microsoft needs to address this as the default Quick Access screen doesn’t always show the most recent saved version of the file.

I have found Win10 to feel very unsafe most of the time with things happening that shouldn’t. I wish MS had just stopped messing around with the code. I guess they were so wrapped up in making it worldwide spyware that they forgot it was supposed to be an operating system.

Someone needs to write an operating system just for music. We could call it Musicus or something…

I didn’t know this, what you type above, but I always load my most recent file from the hub at launch of Dorico. I’ve always done this, already back in the days when using Finale, later on with Cubase and also with Dorico now. This never went wrong, so I’m not sure why it got corrupt and didn’t save correct anymore.

Anyway, I’ve created a new score, copied everything from the old corrupt file and implemented it in the new one. It took several hours before everything was up and running again, with all players going correctly to VE pro, importing and assigning the correct expression maps and so on, but now it appears to be okay again. The file is now saved correctly and, that’s a nice bonus, everything is significantly faster when autosaving and responding to commands.

I was thinking that maybe someone from support would like to receive the corrupt file, so he/she can have a look and maybe find out what went wrong?
If this is a yes, please provide me with your e-mailaddress and I will send the corrupt file to you.

Yes, I load from the Hub as well, but be careful to check that the time stamps on the saved file in Explorer are the correct ones when you’re backing up to external media; I’ve found that Explorer Quick Access doesn’t always show the most recent file.

This was only a part of your problem I know, but what I said is worth knowing for safety’s sake.

We’re happy to take a look at the project, of course, but I’m not sure we’ll be able to work out what happened. You can email it to me at d dot spreadbury at steinberg dot de.