USB Amp Vanished


I have a FiiO USB DAC-E10 used for audio output in Dorico, it came with its own driver which I installed and which Dorico was happily using, but then one day, not only did that driver disappear from the list of drivers in Device Setup in Dorico, but so did the rest of the drivers on the list, including the Generic Low Latency ASIO Driver. So now I can’t hear anything, and I have no way to select a different driver. I would like to also mention that the amp and headphones plugged into it still work with other software as do my other audio output devices (and I can still see the list of drivers in the list shown by the audio output troubleshooter in Windows). Does anyone have any idea how I can restore the list of drivers, or find out what error Dorico is encountering?



Hi Miles,
would you please do ‘Help > Create Diagnostics Report’ from Dorico’s main menu and post the corresponding zip file here? Thanks

Dorico (324.4 KB)

Here you go, Ulf.

Thanks for the data.
The Baios component can be found, but no actual devices; very strange.
If you go to C:/Program Files/Steinberg/ASIO (from my head, I don’ t have access to a Win machine right now), what files do you have there?
And have you tried installing other generic ASIO drivers like ASIO4All or FlexASIO? If they also don’t turn up in the list of drivers, then you have somehow screwed your machine. It would become difficult to help you.

Hi Ulf,

Here’s a screenshot of what’s in that folder, I have tried installing both ASIO4ALL and FlexASIO when I had the previous problem of crackling audio upon playback, but they’re gone from the list, too. I haven’t tried installing any new drivers since they all disappeared from the list. Should I try reinstalling either of those to see if they show up?

That’s all I have in my C:/Program Files/Steinberg/ASIO folder, and my Dorico works fine; so the problem may lay elsewhere.

Alright so I’ve managed to fix the problem; I just tried reinstalling ASIO4All and it reappeared on the list, so I decided to reinstall the driver that I was intending to use, and that also reappeared, and I was able to use it, and now I have sound again. Thanks everyone for you help.

I really still wonder though how you could get into this situation in first place. Ah well, it’s working again, so lets hope it stays that way…

1 Like