USB eLicence not showing up on slave PC

Hello all

Just installed Cubase Elements 6, activated successfully, and downloaded licence onto my Steinberg USB eLicence dongle.

Moved to another PC (one of my studio slaves, not connected to internet) - and eLCC is showing no licence - all functions greyed out.

Checked under Device Manager that USB eLicence protection is installed correctly - all OK.

Have installed latest eLCC on this slave PC (win XP 32bit).

Moved dongle back to internet PC (that I used to activate & download the licence on) - the eLCC scans and finds the Cubase Elements 6 licence, no problem. :unamused:

So the licence is on the dongle - please tell me how I get my 2nd PC to “see” it.

What am I doing wrong? :blush:

Thanks in advance,

I can only think of 2 suggestions.

  1. Make sure the eLicenser on the new install (slave) has been updated to the latest version.
  2. Try a different USB port.
    I can’t think of anything else to try.

Thanks for the reply, jaslan - I’ll try using a different USB port - cheers, Mike.

hmmm…no luck - this is wierd - my hardware is not recognising the dongle at all - and yet the USB ports all recognise a USB memory stick if I put one in.

Must be an OS issue.


I saw in another thread this solution, not my quote, because I use Mac, but I just copy here in case it helps you : it worked for the problem of someone else using W7

Could be ( maybe ) your Win7 Power Plan settings .

Win 7 has a " USB selective suspend setting " hidden away in the Power Options .
It is there to turn off USB ports and save the planet from using electricity in our Green Age , but it can suddenly make USB peripherals disappear

So check ;
Control Panel > All Control Panel Items > Power Options >Change Plan Settings> Change Advanced Power Settings
Then find the USB settings in the tree , and disable the " USB selective suspend setting ".

Sometimes problems like this are caused by multiple USB devices installed to the same USB port. This problem is easy to prevent by using the “safely remove hardware” option in Windows. But now how to solve…

  1. Uninstall ANY USB device in Device Manager (including USB dongle(s)).
  2. Reboot
  3. Plug in the USB dongle

If this is the cause of the problem, Windows will recognize the USB dongle and install the drivers automatically.

Unfortunately, this didn’t work - still showing up as an empty dongle - sigh :frowning:

But thanks to all who took the time to respond - I’ll have to reinstall the OS.


Are you sure the license is on the USB eLicenser and not on a software eLicenser?