USB eLicenser errors on El Capitan, doesn't read at alll

I submitted this off of the Support page, too, but maybe someone here has an idea.

My USB eLicenser works fine on my Yosemite desktop, but doesn’t work on my El Capitan MacBook Pro. The eLicenser utility shows no licenses on the stick (after taking a very long time to refresh after insertion). If I run Maintenance, it has an LCC2 “communications” error at every step. Clearly, it’s unable to read the USB stick.

I’ve tried both USB ports.
Yes, I’m running the very latest eLicenser.
Yes, I did a complete uninstall and reinstall of eLicenser.
No, I do not have the Duet application installed at all. (That’s the closest I’ve seen in the KnowledgeBase to my problem, but I’m not running the 3rd-party Duet app. Note, however, that El Capitan has built-in things named “duet” if that’s a clue. But those cannot be disabled, so if they were the problem, no one would be able to run Cubase on El Capitan.)

Thanks in advance for help - this is costing me business!!

I know I’m not alone when I say that I hate hate hate that damn eLicenser. Steinberg, please get rid of that thing, and let us run a licensed copy on two machines, e.g., desktop DAW and laptop for mobile recording.


Make sure, you have the latest eLCC version, please. Also try to plug-in the USB-eLicenser to the USB hub. Could be, all of your USB Ports are USB3, and could be your USB-eLicenser (maybe an older one?) needs USB 2.

I remember, there was something… Try to search the forum, please. Maybe it’s mentioned even in the Knowledge Base articles.

the problem went away with a new “short” eLicenser. the older “medium” size one was problematic on my macbook pro. so i guess it could be that the MBP USB is 3.0. never mind that the USB spec explicitly states backward compatibility. methinks the eLicenser doesn’t play by the rules…