USB keyboard with Cubase - how?!

Hope someone can help me. I’m a noob so bear with me!

I want use my Motif XF7 to input notes (play!) into cubase, using USB. I have installed the correct USB to midi driver in my PC and have set the XF7 to transmit via USB rather than its midi out. But nothing! Do I need to define in Cubase that a particular track uses a USB input rather than midi. And if so, how?!

When pressing a key, do you see any midi activity on the transport?
Have to read the manual/help files with regard to midi devices?

Suggest you start with the obvious, else we regurgitate the manuals on these pages.

No activity is showing.

Do I need to define in Cubase that a particular track uses a USB input rather than midi? Or should activity still show? (even if I do - and haven’t!)

If your midi devices are correctly configured, any midi track will allow the data source to be “any” or a selected instrument. In other words no, as soon as you start playing, you can start recording. If not…check the midi device config.

Also, know that your USB midi device has to be plugged in before Cubase launches.

Thanks guys :smiley:

Yes Cubase was indeed launched after the usb was connected.

As for configuring midi devices I’m at a bit of a loss on that one :blush: Where exactly do i go to do that?

Many moons ago, after much head scratching, I set Cubase to work with my RME Multiface 2 interface (both midi and audio) and that all works fine. But what do I need to do for Cubase to ‘see’ the USB data?

I do have some vague memory of having to set which port was used for a track’s midi input (or was that on a previous version of Cubase… and no longer applicable). It was a panel to the left of the tracks, but now I don’t see this… I’d like to be able to see this panel. Any ideas?

I half set up Cubase 7 many, many moons ago but haven’t been near it since… hence these half notions!!

:laughing: :laughing:

I think you mean the Inspector, alt/opt-I on the keyboard.

Yes that was it!

Now when I view this, I see that ‘all midi inputs’ is shown as the input. But I see no option of a USB input!

Or does ‘all midi inputs’ include USB anyway? (given that I have installed a USB to midi driver…)

Whatever the case, there’s still no sign of life via USB… help!

Yamaha devices are notoriously iffy when it comes to USB/MIDI. You definitely want to install their MIDI driver on your computer. Then things will go smoothly.

I’ve cracked it! First I had to UNinstall then REinstall the USB MIDI driver, then route the Motif port that THEN appeared to ‘all midi inputs’.