USB Midi Devices Not Working Windows 10

Hello, I don’t believe this is a Cubase issue, but thought I’d ask here anyways to see if anyone has found a solution.

Randomly my midi devices (usb) are not working in Cubase. They are recognized in Windows and show up in Cubase “Midi Port Setup” and are all enabled. However, I get no activity in the “midi input’s” meter.

I’ve tried restarting, unplugging, uninstalling drivers and replugging them back in…these are plug and play devices that do not require updating drivers. Everything used to work flawlessly.

Sometimes I have managed to get it to work by unplugging, shutting down, booting up, and plugging back in…but even that is not working now. I’ve tried the Korg uninstall midi devices tool. I do not have more than 10 devices on windows, so there’s nothing excess to uninstall. I’m at a loss of what’s going on since windows definitely recognizes the devices.

When I use my midi keyboard for example, nothing happens and I get no incoming midi input. I also have a breath controller as well as an mpe controller that all do the same thing.

Any help would be vastly appreciated.


Not sure, if this applies to your scenario, but I once had a USB MIDI issue that ended being solved by changing the BIOS settings to disable legacy USB support.

And I assume, you don’t have some odd Preferences > MIDI > Filter settings being inadvertently set.

And the great MIDI-OX utility software might also be of help to confirm, that indeed the problem is all across Windows, not just Cubase.

Thanks, so far I think it’s resolved but I’m still hesitant to restart anything. I went into device manager and uninstalled the drivers for everything…leaving all devices plugged in, restarting seemed to fix the issue. Thanks, I will look into that and MIDI-OX seems quite helpful.


1 Like