User Shortcuts don't seem to work reliably

I’ve created some shortcuts/keycommands in 9.5 but it seems, that they don’t work reliably. Sometimes they work, sometimes they don’t. There are no conflicts with other shortcuts, at least WaveLab doesn’t tell me about any problems. Are there any known problems with user shortcuts?
Thanks in advance!

Please be more accurate on a given case.

A non-working shortcut for example would be an exponential fade out. By default the key command for that is ALT-F and then 7. But that doesn’t work. Another example which sometimes works is assigning a shortcut to a factory preset of gain function (in the process tab), for example -3dB. I assigned SHIFT-BACKSPACE to the preset and it seems like this function doesn’t work as long as I don’t open the gain functions’ preset menu at least once. After this it seems to work until I restart WaveLab. Then I have to open the preset menu again to make the key command work. Weird.

  1. ALT-F and then 7 works here. But you have to do it in 2 steps: Press Alt + F than release the key.
    Then press/release 7 on the numeric key pad.

  2. Indeed, I can reproduce what you see. After analysing the case, the solution is not easy for me to change for the next patch. But you have an immediate solution: instead of defining the shortcut from the main shortcut page, define it from the related dialog, eg:
    Then it will work as you expect.

Thanks for the workaround, PG. Works great!
ALT-F and then 7 however still doesn’t work here on my end. I’m doing it as you said: I hit ALT-F, release the keys and then press 7 (I’ve tried both 7 on the numpad and 7 on the regular keyboard). No luck. I also tried trashing my preferences but that doesn’t fix either.
Thanks for your great support!

Mac or Windows? Do you have the Montage Clip really selected?

My mistake, PG. I’m not in a montage but editing a standard audio file and want to use the exponential fade out that you can find under process/fading. That being said, I couldn’t find a shortcut that would trigger this specific fade. The only way to do it is to select the desired fade curve via mouse and then hit ALT-O to trigger it, right?