Using a external sound module (Roland Fantom xr rack)

Hi, hope someone can help me? Right, I have Cubase 10.5 pro, Fantom xr sound module, Apollo twin usb interface, Midi keyboard. How can I use, record get sound etc from this set up? Bare in mind, drivers for the sound module etc are not working with current cubase. Hope that makes sense lol. I just wana be able to hear sound from module, record midi & bounce audio file with sound from module.


Plug all devices via USB to the computer. Add a MIDI Track. Set the Input to All MIDI Input. Set its output to the Fantom. Connect the Fantom’s Line Out to any Line In of Apollo Audio Device. Add an Audio track, select the given input and enable Monitor (to be able to monitor the audio from Fantom). Then you can record the Audio track.

Or you can create an External Instrument in the Audio Connections window, if you are on Cubase Pro.

1 Like

Hi Martin, thank you so much for your help. I cant even get drivers to be recognised by win10. Latest drivers roland has is win8. Any advice appreciated!


Oh, that’s hard. You could try to install the driver in the Windows 8 compatibility mode. But it might not work.

1 Like

Hey, yeh it doesn’t work. Tried afew other options, but no luck. Such a shame!

Hey you,
I am wondering what you exactly tried - maybe with more detail we could still help.
I think you maybe dont need the Roland driver at all, because your audio is going from the sound module to the audio interface. Does sound reach cubase this way?
What you need is a midi connection from your computer to the sound module - which maybe works without the driver over usb anyways. Or the apollo has a midi out - then you could connect this with the roland sound module. The audio-path in your case would be via the apollo and so no fantom driver needed for this.
So: Is it clear what the problem actually is currently? No midi-connection? No audio? If the apollo has no midi connectors a cheap midi interface (class compliant, so no special driver needed) would do the job in case the midi connection directly to the fantom is not working because of the lacking driver support.

1 Like

Hi, Elien, thanks for your reply. So firstly ive ordered a midi usb cable, meantime I’ve tried a Midi in to Fantom, OUT to my midi keyboard ( which only has thru. (Nektar p6 keyboard) & a jack cable coming out from fantom to line into the Apollo interface. Created a midi track, with all midi inputs, audio track with input line 2 from Apollo, with monitor enabled but still no sound lol? Further time & advise much appreciated!

Hi you,
could you please sketch out what connections you have established? I mean - the total “picture” for midi and audio. So far I understand that you connected your Fantom’s audio out (line out) to the apollo interface. I assume this interface is connected to your computer via usb and you have the apollo driver selected in cubase. Concerning Midi-connections I am not fully understanding what you have set up: Is the midi keyboard directly connected to the fantom and controlling it this way? Or is the midi keyboard connected to the computer and the computer connected to the fantom?
Thx for taking the time to clarify your setup.


As an additional information: what midi-ports can you see in the studio-setup tab of cubase?

Thx, Ernst

Let me clarify the necessary connections for midi: Your nektar keyboard is connected to the computer via usb and the midi ports of the nektar usb are visible in cubase (this is a prerequisite for things to work). Then the nektar’s midi port is included in “all midi ins” and used as source for a midi or instrument track. The output of this track has to be routed to the midi out that is connected to your fantom module. This can be the original “fantom midi port” (which may be missing because of the not-working driver for the module) or alternatively a midi port of a midi interface (usb) that is further connected to the fantoms midi in. When you set the midi track to record or enable the monitor button (the little brownish one) you should be able to trigger the sound module from your nektar this way.

Thank you for sticking with me! Ok! I have got a midi usb cable now. Connected to the fantom IN, usb side connected to pc. A jack cable from fantom OUT to apollo interface. (Mic 2, line IN) cubase, added midi track with all midi inputs & output as (usb interface) Which is my usb cable connected to fantom. Added a audio track with (Mic 2 line IN) as input. Enable monitor etc. P.s audio signal sound Very bad. Nothing! Lol. If i hit keys on my nektar midi keyboard i can see activity on midi channel. What am i doing wrong?

Hi you,
ok - so your cubase midi track is receiving midi data from your nektar, right? And the midi output of this track is routed to the sound module (via your new usb midi). Have you enabled midi through in the cubase settings (program settings/midi) and did you enable the monitor button on the midi track?

do the midi chanels match what the fantom module needs?

And: Do you have a chance to check whether the fantom module receives midi data? For example with a headphone or so?

Stay brave :slight_smile: you will get it working, for sure (except of course the sound module is broken - hm… having said that: Double check your cables (audio). They are often a source of issues one tends to forget.

I think the fantom xr has a midi led on the front. Does that show any activity?

And: Do you get absolutely NO sound or is it bad sounding now?

You could by the way test whether your fantom xr delivers audio to cubase. Just use one of the demo songs of the fantom manually and see whether audio reaches the apollo and cubase!

Hi Elien, thanks for your replys checking rite now. Quick one, do you know the Apollo twin usb interface? Should i plug my line IN from fantom to front, which is a guitar line or at rear which is mic. I already of a mic plugged in at rear so one more free. Also if you can check the fantom. Just incase im pluging it in wrong. Thanks. P.s i cant post a video on here can i? Just find it hard sometimes to put things into words

Also i just realised if i plug in midi cable IN from fantom & thru on my nektar & hit keys i can see the midi light flashing on fantom. With the midi usb cable it wasn’t flashing. So im guessing the midi connection this why is correct?

P.s just tested the demo songs with headphones sound is there! Also can hear demo song via apollo, speakers to. Also i can hear demo on cubase audio channel inserted & record sound. So at the mo its playing keys, instruments i cant hear

Hi you,
I dont know the apollo interface, but it is obvious that your audio connections are ok. Otherwise you would not hear the demo songs. So there has to be something wrong with your midi connections. Yesterday you succeeded in sending midi from your keybaord to cubase. So the issue seems to be with the midi connection from your computer to the fantom module. As far as I understood you used your midi usb cable for sending the signal from your computer to the fantom. I assume there are TWO midi (DIN) connectors on this cable. Did you use the right one to plug into the fantom?
And: Dont forget to enable midi through in cubase (program settings) and enable monitoring (the little brownish button with the speaker icon).

I jus cant make this work & give up! Really appreciate you guys help & advice. Seriously.

God bless!

hi you, I d like to encourage you not to give up.

I suggest that you create screenshots that show your midi connections in the studio setup window and a screenshot that shows your midi track (inspector open with the midi in and out visible).
You are absolutely close to a solution I think. Maybe you can also tell us what usb midi cable you use!

Dont give up. It is worth the learning curve!

1 Like

Ahh! Lol. now my nektar keyboard not working midi? Mackie control is but not keys. 0 midi! Dont know what i mite have changed? I can see all the ins & outs visible