Using a Korg NonoKontrol as hardware faders for INPUT channels only

Can someone give me SIMPLE, STEP-By-STEP instructions on how to get a Korg NanoControl talking to my Cubase 10.5Pro rig? I want to use it for hardware control of the INPUT channels - i have a pair of Behringer X-Touches managing the output side, but just want to be able to select, mute and adjust the input channels without faffing with a mouse constantly.

I know it’s possible with the various Generic Controllers etc, but I DON’t want the Nano to be controlling the output channels or vice versa…
Don’t care that it’s not motorised, just want something physical to be able to up the input level on a mic or guitar from the desk…





Yes, use Generic Remote. In the Generic Remote, you can define, which Channel Slot is going to be driven.

Do you use stable count of inputs?

I have a template that i use for maybe 80% of setups, some older projects will differ…
so the template normally should be a standard number of inputs, not all get used, so ideally I would like to control the 8 most commonly used. - 4 mic, a couple of stereo ins and two mono inputs


OK, then it’s simple, you can use the Generic Remote Device.

The MIDI commands are bind to the Fader slot (not the specific Fader or Channel). So in the bottom part, just use:
VST Mixer | Stereo In | Volume
VST Mixer | Stereo In 2 | Volume

No Joy…

Tried the Nano in both Mackie and CC modes…
Briefly… it was able to move the fader from 0 to full (nothing in between) and to mute each of channels 1-8 but i can’t get it to even do that any more.
Even when it did that, none of the Mute lights came on other than a brief flicker as the button was pressed.
Cubase sees it - recognized it and assigned midi in and out correctly… it’s plugged directly in to the PC usb port in case a hub was a problem, but that also made no difference.




Do it in the CC Mode and the Generic Remote Device, please. I’d you want to get the visual feedback on the hardware, don’t forget to emerge the MIDI Out Port and the Transmit flag, please.

If I’m not mistaken there’s a combination of buttons you should press while connecting the korg-nano if you wish to use it as a “mixer”.
I don’t remember if that is something you need to do every time or that combination is to be used only to switch mode (and by “mode” I mean general Cc controller or mixer).


I guess, you are talking about the Mackie Control Mode here. But this is not the right mode, because in this mode it skips all Input Channels. Therefore you have to use the CC Mode, to be able to assign the Input Channels in the Generic Remote manually.

There is a set of buttons… Next track, prev track and cycle that you hold down while connecting the usb to put it into “Not- Mackie” mode

Ric Kelly
guitarist, musician, songwriter.

“While pressing and holding down the SET MARKER and CYCLE buttons, connect the USB cable from your computer to the nanoKONTROL2 and engage CC mode”

Thank you Martin…

Checked back and the combination I said earlier was the factory reset…

Ric Kelly
guitarist, musician, songwriter.