Using a midi keyboard with Cubase6

Hi!
Can anyone help me with the following- apologies if the answer is simple- I’m not an experienced Cubase user. I am using a Roland RD300GX keyboard with Cubase 6. I can get it working fine using midi and accessing the sounds in the VST instruments in Cubase. What I want to do though is use the sounds in the keyboard itself, whilst recording just the midi info and then playing back using the same sounds from the Roland. In essence, therefore, I’m just trying to record the Roland midi info. It should be straightforward? But I just can’t get it to work. Am I being thick lol!!
Many thanks!

Keith58

If you want to use the sounds from the Keyboard., you need to also establish an asudio connection between the Keyboard and your audio interface.

Well, as usual with Cubase, there are a few ways to set this up.

Possibly the coolest way (if you’re using the full version of Cubase) is to set up an external instrument in Cubase’s VST connections. To do that, you’ll need to make sure you’ve got your keyboard’s audio outs hooked up to inputs on your audio interface (as thinkingcap said).

Once that’s done, go to VST Connections, and then click on the external instruments tab. Assuming your instrument has stereo outs, you’ll be looking to set it up with one stereo return and zero mono returns. Once that’s done, you select the inputs on your audio interface that you’ve hooked your instrument up to as the returns for the external instrument you just set up in VST connections. This will allow the sounds from your keyboard to get into Cubase.

Once that’s done, you’ll need to associate it with the MIDI side of your keyboard. To do that, on your new external instrument in VST connections, click under the “MIDI Device” tab where is says “No Link”. Then go under MIDI Devices and “Create Device” The default settings will likely be fine, so name your device (I expect you want it to be the same name as your keyboard), and then click OK. Now before you do anything else, click on the same spot where it now has the name of the MIDI device you just created. This time go under “MIDI Devices” and then click “Open MIDI device manager”. Once you do that, select the MIDI device you just created. Then where it says “No connection” on the bottom, click on that and select the MIDI output port of your keyboard, this will allow MIDI to flow from your keyboard into Cubase and back out again so that both you (by playing “live”) AND Cubase (by playing back the MIDI you record on the instrument channel you’re about to create) can send MIDI to your keyboard in order to play it’s sounds. Now click “OK”.

ONE LAST THING you’ll need to do, is turn off the local control of your keyboard (as the MIDI will all be traveling through Cubase now, and if you have local control on, you will always hear your keyboard sounds (as long as the fader is up that is) no matter what midi track you are actually trying to control with it in Cubase. If local control is off, it will only play sounds from the keyboard when your new external instrument is record enabled or monitor enabled.

OK, NOW you’re finally ready to add the instrument. Go to “Add an instrument channel” and under Steinberg --> External Plug-ins" (or similar) it will now show up as the external instrument you created on VST connections. Select it and Viola! An instrument channel that is now controlling (and controls) your external instrument. It acts just as a regular VST does except that you can only have one in the project (because you only have one keyboard tone generator). And you can still use your keyboard as a midi controller for other tracks when you turn off record enable (and the monitor) button on your newly created instrument channel. Make sense?

As I said, there are other ways to do it… so if you have trouble with this way, don’t lose heart. This is just the slickest way–because once it’s set up, you won’t ever really have to think about it again. BUT this way will only work with the full version of Cubase, so if you have Elements or Artist, you’ll have to do it another way. :slight_smile:

Thank you so much for the full reply! Much appreciated! I am using the full version of Cubase so hopefully that will solve it.

Thanks again!

Keith

Hi Im having a similar issue with my Roland rd300nx, I can set up in midi devices and get to the point where I am getting sound from my Roland but its only GM sounds I cant get an control over the patches and tones from my Roland, started to read more of the midi devices manual but its all very confusing, surely there must be an easy walk through, or are there no ready made xml templates for these.
thanks

You do not need the MIDI devices, you should read SLD Music’s post, or should he post it one more time for you…?

Hi, Gethsemane.

Again… lots of different ways to do what you want. :slight_smile: In a simple implementation, thinkingcap is correct in that you do not need to set up any special crazy MIDI device for your keyboard in order to implement program changes. Once you’ve got basic MIDI communication set up between Cubase and the Roland, you’ve got everything you need–well almost… :slight_smile:

The next step after you’ve got both MIDI and sound working the way you want it, is to understand the MIDI implementation of your particular keyboard (see below for a link to this information). In the case of the Roland RD300nx (as is the case for most MIDI keyboards), you need to send a special combination of MIDI messages in order to affect a single program change. You can do this within the MIDI clip key editor. Go down to where the controller editor where the velocity information is. Click on that “velocity” tab, and you’ll get a list of CC controllers you can send messages on. You are looking for three controllers specifically. The first one is “CC 00 --BankSel MSB”. The second one is “CC 32 – BankSel LSB”. The third one is “Program Change”. If you don’t see one of them, you can make it appear by using the “setup” option). You must send a combination of commands in that specific order (with no intervening MIDI between those commands) in order to change BOTH the bank AND the specific program within that bank. If you DO NOT do that, or the messages get interrupted, the keyboard will likely not change to the voice you WANT it to change to. It may still change with the “program change” command, but without the bank MSB and LSB immediately preceding it, it will not change to a different bank, it will only change to the program within the bank that it’s currently on.

So first you would select “CC 00 – BankSel MSB” Then you would use your pencil tool to draw in a single point a few beats (or measures) before your notes start playing. Once you’ve drawn that point, go up to the info line in Cubase, and change the “VALUE” of that point to “84”. Next you’ll want to select “CC 32 – BankSel LSB”. Draw in another point just AFTER the first point you made, but again well before your notes start playing. Set this point’s value to “2”. Finally select the “Program Change” controller. Create a third point, again, after your last point, but before any other MIDI events. Set that point’s value to “3”.

Now… when you set the cursor before all three of those points, and then play the midi track, a full bank and program change message should be sent, and responded to by your keyboard. It will change the sound to the “spacegroove” preset. :slight_smile:

You can look here to find the “live set list” of your keyboard–in it, they tell you exactly what numbers to set to get each voice.

http://lib.roland.co.jp/support/en/manuals/res/62474215/RD-300NX_V200_List_je01.pdf

Again, this is only one way to do it. And things change depending on what keyboard you are trying to control. Roland uses numbers in the 80s for its bank presets. Yamaha uses numbers in the 60s… it all depends on how the manufacturers decide to implement their midi. You can also set up presets by name that you can set in the inspector of the midi channel if you want, but that DOES require setting up a special MIDI device and then a lot of time consuming work creating the presets.

Hope this helps.

Hey guys!

I know Keith very well… lol…

To explain a little further… all he’s trying to do is to record midi from the roland and then to trigger the onboard roland sounds from cubase so he can tweak the midi perfomance in the midi editor…

i’m pretty sure he has all his connections set correctly as i’ve just talked it through with him over the phone…

SLD… am i right in assuming that it’s not possible to just hook up a couple of midi/audio leads, switch local cont off on the roland and play/record midi from the roland directly… rather you have to select which sound/bank on the roland you wish to trigger via midi messages in cubase?.. it does seem a bit of an arse about face way of doing things :confused: he’s not trying to use it’s multi-timbrality, just to access its sound as you would in a performance if you follow me…

Mat my second reply was for Gesthemane directly. My first reply gives instructions for doing exactly what you want. :slight_smile:

You DO NOT need to send MIDI messages through Cubase to change the sound bank on Keith’s Roland. You can just do that at the keyboard itself. I only mentioned this method to Gesthemane because I thought he was asking how to make program changes via midi instructions so he could change sounds in the middle of a song.

Also, Keith doesn’t need to set up an external instrument if he doesn’t want to. At it’s most basic level, all he needs to do is have control over both the MIDI and the audio of his keyboard. Instead of an external instrument, he COULD create a MIDI track that is attached to the MIDI in and out ports on his keyboard (i.e. create a MIDI track and assign it’s input to either “all MIDI” (not recommended) or specifically to the keyboard’s MIDI output port, and assign the MIDI track’s output to the keyboards MIDI input port). This establishes the MIDI connection. Then as far as the audio, instead of creating a external instrument he could create a new INPUT in VST connections and assign it to the audio interface inputs where his keyboard audio is hooked up. And then he could create an audio track in the project and set it’s input to that INPUT he just created (in this case, though, the monitor button for the audio track would have to be activated to hear the keyboard’s sound when you play it–and if local control is off, the monitor button OR the record enable button would have to be enabled on the MIDI track in order for the MIDI to reach the keyboard–and therefore here the keyboard when you play it).

Just remember. You have to deal with both the MIDI connection AND the audio connection. If there’s any issue with either one of those (i.e. wrong MIDI connections, monitor buttons in the wrong position, or if “MIDI thru” is not activated in preferences, etc.), there may be issues with hearing the keyboard sounds as you expect.

As I said though, creating an external instrument is slicker and easier to work with. In EITHER case, he can opt to send control change messages via MIDI, OR he can simply go to the front panel of the keyboard and change the bank and program to whatever he wants himself.

Many thanks, I have managed to find patch scripts on the Roland USA site.
Here is the link
http://www.rolandus.com/support/patch_script_builder/action.
There is also a pdf with instructions
Worked for me in Cubase7
Thanks for the replies
:smiley:
Ps if anyone needs help just reply and will help if I can,

Gethsemane,

Very cool! That saves you a ton of work. :slight_smile:

Hi again SLD and thanks for the reply…

Yes that’s the exact method I’ve been using for the past 25 years or so with every workstation, synth and drum machine I’ve ever owned… The problem seems to be that although the Roland is receiving data it’s not playing back what’s on its global channel… It seems to be playing one of its GM sounds instead… As you’ve so kindly stated several times it SHOULD be that simple… Unfortunately it doesn’t appear to be lol… I think he’s going to hit the Roland UK forums to see if anyone over there can help too…

Big thanks to SLD for the time you have spent on this issue. Much appreciated!

Keith

Hmm… That is odd. Sorry it’s not working right, fellas. Maybe it’s a MIDI channel issue? Sounds like it’s something to do with the Roland keyboard though–maybe there’s a setting that has the tone generator output General MIDI sounds in response to MIDI signals? Or perhaps you’re trying to send an actual General MIDI file somewhere in the project to the keyboard which has sysex messages that instruct the keyboard to go into General MIDI mode? I’m sure you’ve thought of all this already. I’m just spit-balling. :slight_smile:

Anyway, I’d be curious to know if you find a solution.

Sorry I couldn’t be more help.