Using ALT for Copy event

When using the tool modifier for copy event (alt key), it does not always work, it moves the event instead.
It seems random, but if I click on the event and hold down the alt key for say 3-5 seconds, it seems to work more consistently. I usually have to try 3-4 times before it actually copies the event.
It has always been like this with Nuendo.
Am I missing a setting?

No, I fixed this issue with a macro (sorry, I’m not in front of my station) :
Copy
select a track below or above
Paste

It works like a charm with a Alt + Shift +up/down arrow shortcut.