Using Ample sound with Cubase 9

Hello. I just wanted to add some guitar to my tracks and fell into testing Ample Sound guitars. I am on a pretty ok i7 4900 4gkzh 16 gb ram PC with Cubase 9 on and was a bit stumped when I saw that the CPU peaked out using only this ONE VST plugin. Any suggestions what settings to use in Cubase to lower the load?

Try changing your buffer settings, check if any fx’s are running, try ASIO Guard.

Thank you for the suggestions, what buffers? Audio? How do I check if FX are running, isn’t mute enough? Will look at ASIO guard.

Your sound card buffers. I meant any used fx in Ample Sound itself. I don’t use them, you might want to check if any are on then disable them.

Ample sound plugins are pretty meaty eaters of resource. I have AGL and I find that if I turn down the resonance settings I get a bit more out of it. Also do not use the pedal to sustain notes.

Hi there

I use ample sound guitar and bass all the time with no problems at all, my machine is not as powerful as yours, I’m running a latency of 192 samples, not sure what’s causing your hassles.

Best Regards


Thank you, I will be looking into it. As it was the demo really discouraged me from getting AmpleSound.

Ok, well I dont have my machine set for so much latency. I could try and test with that.