Using automation while looping (fixed in release 9.0.30)

Hi,
I am doing something very simple: a midi track is played on 4 bars. A MIDI volume automation is set to lower volume at the beginning and set back to high volume at the end (4th bar). See the attached image.

If I play it it will work fine on first loop but then the volume will be set to high after the first loop (back to bar#2), instead of staying the same (lower) volume level. Why ? How can I make it stay the same or even chase the last automation event which should set it back to lower volume ?
Please advise. Thanks !
Use Cubase Pro 9 on the Mac.

Any hint ? Someone ? Please…
I MUST be doing something wrong…

Does the fader move on the mixer?

How did you record the automation or did you draw it in?

Thanks for taking the time…
The MIDI volume fader moves down on the first loop but then does not move although I hear it loud again (when it starts playing the second loop). The synth (audio) fader never moves. But I can see (and hear) that the sound is louder. Again the problem occurs only if I cycle the playback. So to be clear:

  • bar#1 plays with volume going down (volume cursor in the mixer moves down)
  • bar#2 plays with low volume
  • bar#3 plays with low volume
  • bar#2 plays with HIGH volume (no volume cursor in the mixer moves)
  • bar#3 plays with HIGH volume (no volume cursor in the mixer moves)
  • bar#2 plays with HIGH volume (no volume cursor in the mixer moves)
  • bar#3 plays with HIGH volume (no volume cursor in the mixer moves)
  • etc.
    This is driving me nuts !!!

I did another test:

By using the settings above:

  • Bar#1 played with a vol=45
  • Bar#2 played with a vol=45
  • Bar#3 played with a vol=45
  • Bar#2 played with a vol=90 (although the mixer cursors did not move I could hear the same volume as if it was set to 90)
  • Bar#3 played with a vol=90 (although the mixer cursors did not move I could hear the same volume as if it was set to 90)
  • Bar#2 played with a vol=90 (although the mixer cursors did not move I could hear the same volume as if it was set to 90)
  • Bar#3 played with a vol=90 (although the mixer cursors did not move I could hear the same volume as if it was set to 90)
  • etc.
    It seems to me like a bug (or, to say the least, an unnatural behavior…).
    Also note that if I remove the automation while it is playing at the right level (45), the volume stays at 45, which is the normal behavior.

Don’t know what’s happening there but you’ve got work arounds.

You’re saying midi volume - so is that a midi track routed to a rack instrument retrologue?

Use a track instrument and automate the volume that way or use midi automation in the piano roll.

Thank you for your answer. But what you are suggesting is to use an Instrument track, and the automation will modify audio settings. In my case I am using a rack instrument and the example I picked was to give a simple case where it does not work as it should (in my mind). In reality I am using a more complex setup and (for instance) I had the same problem as in this simple example when automating a MIDI parameter. So I need to find a solution using a rack instrument and automating MIDI parameters (MIDI controllers, etc.)

I’ve just checked this out and I agree, there is definitely an anomaly!!

I used the Midi Monitor to see what it was doing and indeed, when it reaches the loop point it transmits a rogue MIDI value.

I tracked this down to it transmitting the last MIDI value in the lane, and in my screenshot you can see that my last value is 99 (in the Status Bar) and even though it’s miles away from the right hand side of the loop I’m using it gets transmitted, as shown in the MIDI Monitor. I’ve validated this by moving it and adding/removing other points. Always the last point on the lane.

Well, anomaly, I’d say actually a bug IMO. And it does explain why at times I used to have problems with automating volume of my external instruments. These days I do most automation using the audio channel for VSTi’s and I don’t use external instruments so much…

Mike.

Glad to see that I’m not the only one with this problem. :slight_smile:

As a matter of fact I filed a bug report:
https://www.steinberg.net/forums/viewtopic.php?f=253&t=119313

If you can add your “voice” (reply) to that post it might help trigger some interest from Steinberg support…
Thanks for checking it out anyway.

It’s been fixed in release 9.0.30 !

Great :slight_smile:

Mike.