Using Elements 8 with a 2-ch Scarlet Focusrite 2i2

I’ve used WaveLab 5 for a very long time with no issues. However, with Elements 8 when I create an empty document and choose the audio properties such as stereo, sample rate and accuracy (stereo, 24-bit, 44 100 Hz) I then hit record and I see the audio in the left side of the recording but when I stop the recording I see no wave above the transport area.

Funny thing is that when I go to the directory that I specified for the location of the recording the wav file is there and I can open it in Windows media player and it plays.

Plus if I choose (stereo, 24-bit, 44 100 Hz) for the audio properties, shouldn’t I see the audio in the left and right area of the recording area?

WaveLab 5 always show my mono tracks in both the left and right side.

My system is a PC, Windows 8.1, 32GB memory, 1TB of storage, 1.5 GHz CPU, 64-bit version of Elements 8.

Any help would be much appreciated.

David
Recording with no right or wave in edit area after stopping record.jpg

In Elements 8.0.4 Win 8 I see the same problem. “Create new audio file window”, the window isn’t created. Does seem to be a problem there. But “Add to focused track of montage” seems to work, and creates a new montage if there isn’t one.

Re: the stereo file, I don’t know why Wavelab 5 would make left and right channels in a stereo file if the input is a single channel mono signal, unless you were feeding it in equally to both channels. Wavelab 6 and 8 don’t have an option to route one channel equally into 2 channels during record afaik.

I think one solution is probably to set the record file parameters to mono instead of stereo, making a mono file, and then if you need a stereo file for iTunes or something, render the mono file to a stereo file.