using external instruments or FX processors causes crash 100% repeatable

This is 100% repeat crasher.

OS 10.15.6 beta3
CU 10.5.20
iMac i9 2019 40gb 512 SSD media on SSD via TB3 case
Tascam 20X20 on direct USB3 port connection, @ 96K/24 external clock locked

Setup external FX processing. Go to audio connections and setup routing a ch to and from processor ( DDL ). I”m using CH 10 analog line level to go in and out.

Everything at this point works ok. great. You can route audio or VST interments thru the external FX via FX track and all is good. Save project. Quit Cu

Restart app, load project. Progress dialog stops at initing fx track using the external track, pauses for a second, app crashes / vanishes.

I have crash logs and screen shots of setup of audio connections.

This is also repeatable for setting up external instrument like synth module using CH 3/4 for input as part of setup. Same crash.


actually even without having external fx or instrument connected to I/O ch, I’m STILL crashing loading project due to use of ext inst or fx.

I dumped Logic because of its problems and for features Cu has L doesn’t, but L was normally pretty stable. this is insane. one work stopping bug after another. refund ?

S


UPDATE : after wasting hours, all nite really, it all finally came back to working. last nite. I created new empty project, imported tracks from previous project, set up clean new routings with hardware. it worked w/o crashing. the orig project created in 10.5.20 is corrupted some how. once I had new clean app prefs and rebuilt from the ground up. it worked last nite. Project also opened up ok today. That said because I didn’t set the BPS in the new project to match the old project, that basically screwed up everything on timing. I guess I can redo the import with project at correct BPS but really Cu’s handling of media timing is appalling and almost always the exact opposite of what I want - don’t retime it unless I explicitly ask that to happen.