Using Groove Agent pattern in Cubase track - missing/corrupted info

Hi there, hoping someone can point me to the right info.

I’m using Cubase Elements 10.5 with the inbuilt Groove Agent. When dragging a Groove Agent pattern across to the track I’m working on in Cubase the Groove Agent track is not playing correctly, often missing sounds or using other effects/sounds instead. It will play correctly when I preview it in Groove Agent, but plays corrupted once it’s in my Cubase track and being played from there.

Any thoughts or tips to correct this? Even pointing me to the right section of the manual would be super helpful.

Thanks so much in advance

I have elements 11 and it does the same. You audition a loop in groove agent and drag and drop in drum track and it not the correct one always playing, often one of the fills. I usually delete the one causing the problem and it mostly works ok. I can’t remember having this problem in 10.5 AI or wasn’t aware it was happening as Cubase was all new to me at that stage. There is obviously a fault in some of the loops?

1 Like

Hey, thanks for the reply.
Yeah, I’ve been doing the same, but sometimes every loop I want is glitching. Pretty annoying.
Hoping there are answers somewhere. If I find anything I’ll post here to update you too :blush:

This issue can happen when using Acoustic Agent presets.
You should try to activate the small “P” MIDI- icon below the pattern pads.

from GA 5 manual:

Using Different MIDI Channels/Ports for Instrument Pads and Pattern Pads

By default, instrument and pattern pads share the same MIDI port. If instrument and pattern pads are both assigned and share the same trigger note, the pattern pad always gets priority, therefore, instrument pads that use the same trigger note as a pattern pad cannot be played via the same MIDI port. In this case, you have two options: You can set up a different MIDI port or a different MIDI channel for the pattern pads.

It is recommended to use either of these functions or combine them, in order to control pattern and instrument pads separately.

2 Likes

Hey, thanks so much for this info, I’ll definitely check this out next session. Hopefully this will do the trick. Cheers :blush::+1:

Hi there,
I found a fix for this. When you open a drum kit at the bottom left of the page there is a little symbol next to Omri ? Click on the symbol and it will turn yellow and that seems to fix the problem which is connecting to the correct midi out channel.

1 Like

Thank you so much! Will give it a try next session for sure :+1::blush:

Hi Oneway,
Thanks so much…yep, simple as it was it seems that little icon has fixed the issue. Legend!! :blush::+1::metal: