Using Neutron 4 in Cubase 12

Previously i had crashes here and there with Izotope plugins and may have found an answer.
After uninstalling Neutron 3 it left behind a couple of Neutron 3 vst 3 modules in common files.
I had to uninstall and re-install and found out the best way was to uninstall by going to control panel and then add and remove .
This now highlighted the leftovers. I think that a lot of crashes with Izotopes plugins is the Product Portal nevers seems to uninstall everything, so it is worth checking your Common files.
So much for the Product Portal huh!!
My biggest frustration now is after installing Neutron 4 , I get a welcome screen after every instance I put on tracks and master.
Does anyone know how to disengage it permanently??

All the Best

I just tried this. The first instance I added put up the welcome screen, then I pressed the Skip button. When I deleted that instance and added another instance, there was no welcome screen. I don’t know if it would come back if I started another Cubase project or session as I was just trying it within one project and Cubase session. (I don’t recall if I’d ever pressed the Skip button before in trying out Neutron 4 – haven’t used it all that much, and I think there may also have been an update to it since I did try it out.)

As for the iZotope uninstalls, the Portal only uninstalls relatively recent iZotope products. To uninstall earlier ones, you have to go into Control Panel’s Programs and Features (if on a PC, or probably some equivalent is on a Mac), or find the uninstall program in your file system to uninstall. No clue if those fully clean up after themselves, but I recently did go on a mission to uninstall a bunch of older iZotope products that I’m either not likely using in archived projects or that I just don’t care about coming back when I am (e.g. because I’d probably replace all the plugin processing they were doing anyway if I’m going to remix).

Hi Rick

I do get the welcome screen back when i start a new project which is annoying.
There seems to be no way to get rid of it.
When i first updated to Neutron 4 i pressed skip and when to access anything in Neutron 4 the program froze and also Cubase 12 froze.
I had to go to task manager to resolve.
Once the welome screen was gone everything worked.
What i did was press skip and save a blank project without touching anything in Neutron 4
That was the workaround
Since getting rid of the old Neutron 3 entirely things are working out ok but still the Welcome screen returns after every incidence in a new project until the first save…
It is just a little annoying.
I have yet to test Ozone 10 properly as Ozone 9 kept freezing and made Cubase 12 disappear.
It was a random crash when pressing the reference track and the track that i made and track matching.
I sent Crash dumps to the staff on the forum and they said it was an Ozone problem and you could see that in the crash dump once opened.
I wrote to Izotope, but they said try this and that , but it never solved the problem. I sent another query in , but never heard back.
You pay good money for these things but not a lot of help from Izotope so far.
Again it may be due to older Ozone remnents hanging about.
Today i will have a good check in the program files and the Common file folder.

All the Best

I just tried this in a different project and different Cubase session (and different Windows boot session, for that matter), and I did not get the Neutron 4 welcome screen. The project was an existing one, but it did not have Neutron in it (and I also did make changes to the project, both since opening it and since last saving it during this session). I still do have older versions of Neutron on my system (it looks like both 1 and 3 Advanced – not sure why I’m not seeing 2, but I was recently uninstalling some of the older iZotope plugins that I was reasonably sure I didn’t use on final projects, and I know I definitely used V1 extensively on one specific project).

As for Ozone 9 plugins crashing Cubase, I definitely saw some problems with the Ozone 9 Imager where, at least in the one context I was actually trying to use it, it would consistently crash Cubase (no error message visible, just disappearing). I don’t recall having problem with the other Ozone 9 plugins I used (mostly the Maximizer, though), and I haven’t had any issues yet with Ozone 10 (but I think I’ve mostly been using the “mothership” plugin, as opposed to individual module plugins – I really like the enhancements to Master Assistant, which finally make that useful to me).

Hi Rick
I still get welcome screen with any new project,annoying.
I have wrote to Izotope again
Just by you mentioning that Cubase 12 disappeared when using Imager and mine disappeared going between Gain Match and Reference and my own song, shows that something in Ozone 9 triggers similar disappearances and Izotope should check this out.
I have yet to check out Ozone 10
Still yet to hear back from Izotope
The Cubase Dump files showed that there was a problem in Ozone 9 but did not give an explanation.

All The Best

I probably was not trying the Gain Match/Reference stuff in Ozone 9 as I really did not use Ozone 9 much for mastering, other than just the Maximizer (mostly due to the Learn Threshold part to help get a target LUFS level) as the next-to-final stage in my mastering chain (only later stages were fades on the Stereo Out, then PSP X-Dither post fader). I never found the Master Assistant in earlier versions of Ozone to give me even close results to what I was going for, so was mostly using other plugins, especially Waves AR TG Mastering instead.

With Ozone 10, though, the Mastering Assistant is vastly improved to make it easy to get close, be it for one of their genre references or for targeting something similar to a specific reference recording you’ve got on your system, and the ability to make adjustments in the Master Assistant view can get things even closer to desired results before going to any of the individual modules for final tweaks. I have used the Gain Match and Reference stuff in Ozone 10 in Cubase Pro 12.0.40 without problems, too.

FWIW, I had my first hang (not crash) with Ozone 10, specifically with the Ozone 10 Dynamics module. I was trying to select a preset, then pressed Play on my controller, and Cubase Pro 10.0.40 hung. I gave it upwards of a half an hour to make sure it was really hung, as opposed to just going through something glacially slow, before forcing a DMP file for analysis, which did have Ozone 10 Dynamics in the call stack.