Using Steinberg UR-44 as a DI box


I’ve been using Steinberg UR-44 as a reamping tool to simultaneously record a DI signal and the processed signal from my POD HD500X, but something went wrong and it stopped working.

So I’ll explain what I need to do first:
As the VST amp sims introduce latency, I need to have a monitoring channel on that’s fed by my POD so I can hear what I’m playing with minimal latency possible. And at the same time I need to record a DI so I can get a better tone for the recording.

What I’ve done before is quite confusing since you can’t (or at least I havent found how to) route a specific input to a specific output on a UR44. I’ve done the following:
Guitar is connected to Input 3 on the front panel, then line output 2 on the back panel was connected to the input port of the POD, then 2 outs were taken from the POD and connected to line input 5 and 6 on the back panel. In Cubase I routed it as Input 3 for a DI, then for output to the POD I used an output bus with Mix 2 L, and for the Amp Input I added another bus with inputs 5 and 6.
Essentially I was able to capture both the DI and the Amp sounds. However, outside of cubase I guess it would loop and produce a loud constant beeping noise until I turned the POD off.

The question is: is there a better way to route the UR44 so it can both capture the DI and send it as a mono signal to the input of the amp (POD in this case) without using a DI box, and why would it suddenly keep beeping in cubase now? I haven’t changed anything and I doubt this routing could in any way damage the interface as it’s never been left on beeping or any other issues ever appeared.

Interesting thing is that when I unplugged the outputs of the amp, the right one going to the Line input 5 was acting as a loop, meaning if I plug it into the guitar it sounds as a guitar should, just mono. When I switched cables and inputs on the UR44, I only got Line Input 5 working that way, Line Input 6 wouldn’t produce any sounds.

The issue would be solved if you could dedicate one input to only one output, but now it seems like my Line In 5 and 6 feed into the output connected to the input of the Amp. It’s also quite confusing which outputs of the UR44 are 1 through 4 as it’s named Mix 1 L and R, Mix 2 L and R, and FX Bus L and R in the output settings in Cubase.


Maybe I am missing something here, but to me it sounds there are two easy solutions:
First off, if you are only using the Pod to hear a processed guitar, why don’t you just use the amp sim built into the UR44? I know guitar players are picky, but most guitarists I record are fine with the Yamaha amp sims for recording purposes.
Or, if you want to do it your way, just split the guitar signal before the pod, send one directly to an input and the pod signal to another input (monitoring the pod input of course).

Hey there!

The reason why I wouldn’t use built in amp sims is dynamics. With my style of playing it’s just tough to get the feel right without certain elements in the process chain, such as precise gating and specific pre-eq. I guess it works perfectly fine if mostly chords are played.

As for the second option -yes, a DI box would do the thing. But UR-44 is so capable that I doubt there’s actually no way to do it through the interface itself. That’s the challenge and the question.

I just waited an hour or so after posting this and all started working as it had been before. Input 3 is DI, Output 2 on the back panel goes into the amp, and 2 outs of the amp go into Line In 5 and 6. In cubase I left routing the same - Input 3 for the DI, Inputs 5 and 6 for the amp signal for monitoring, and Mix 2 L as the output bus that’s essentially forwarding the DI signal into the guitar input of the amp. It all works perfectly fine besides minor noise being added, but it’s quite confusing why Line Output 2 is marked as Mix 2 L in Cubase. Also I’m not sure if any settings in the dspMixFx UR-44 software affect anything in Cubase. Probably not as it says the interface is taken over by another application when trying to use the dspMixFx while Cubase is open, but still - maybe someone knows?

When you use Cubase you still control the same things, it’s just that you do it form within Cubase.

Glad you got it working again!

Btw, I did not mean you should use a DI, a simple signal splitter (Y cable) works fine.