Using Superior 2.0 in Cubase 6

I have all the paths set to cubase\VST plugins, but when I bring up the VST instrument track superior is nowhere to be found. Anyone have any Ideas?

See if it’s listed in the Blacklist.XML file in the Cubase App Data folder and if it is, delete the file and re-start Cubase.

Where is the Cubase app data folder?

Did you try loading it from to the VST rack? Sometimes certain VSTs give me issues when trying to load them in instrument tracks (specifically huge multi-output ones like S2.0).

Aloha K
Very interesting post. I also thought that I noticed that
but was not sure.

I believe my NI stuff works better in loaded in
the rack and not as an instrument track but I
though NAW!! It must just be me.

SampleTank and VST Collection stuff does not seem to matter
but with my NI stuff, yes.
The rack seems to be more stable and efficient.
But maybe I’m wrong on this and it is just me.

Thanks so much for the post.
I’d like to read more on this and see if more folks have noticed this?
{’-’}

Superior 2.0 works fine on instrument tracks for me (on Studio 5). It seems to me that the OP just hasn’t pointed Cubase to the correct .dll location. I read his posts on the Toontrack forum also. The mod there explained exactly how to do it but he seemed confused.

So, once again …

Devices > Plug-in Information > VST 2.x Plug-in Paths > Add … Choose the folder where the .dll is located … OK … Quit Cubase … restart Cubase

I don’t have 6 yet but I think it should be a similar procedure, correct?

Well it’s not that I’m confused (although I have no idea what I’m doing lol) The problem is that even though I have paths setup to go to C:program files\common files\steinberg\VSTplugins, and C:Program files\Steinberg\VSTplugins, When I open a VST instrument track SD2 is not there, its not an option.

Where do I find this VST rack?

Have you installed Cubase in 64 bit or 32 bit?

Regards,
Stephan

If you went with the default paths when you installed Superior the .dll wont be in either of those folders. Did you tell the installer to put it in a Steinberg folder? If it isn’t there Cubase can’t find it. You need to find where it is and add that folder to your plug-in paths.

Did you search through all your Toontrack folders for Superior Drummer.dll? Whatever folder it is in is the folder you need to add to Cubase. I don’t know if it is in a Toontrack folder or maybe a generic VSTPlugins type folder (since I did a custom install and directed it to my Cubase folder from the start).

If I remember correctly you said on the Toontrack forum that you can launch the Toontrack Solo standalone app and it shows V2.2.3(64-Bit), right? So you know you have it installed somewhere.

Open Toontrack Solo. At the top left of the screen you will see Options. Click on that. Then you will see Set Paths. Click on that. Whatever path is listed in Solo is the path you need to add in Cubase.

I guess there is a chance is got blacklisted but I doubt it. You can find the App Data folder by going to the Windows start menu > All Programs > Steinberg Cubase.

If you can’t figure it out from here I don’t know what else to suggest. :confused:

Most plugins will install their .dll in c:\program files\vstplugins, so point cubase to that directory as well. (c:\program files(x86)\vstplugins if you’re on 64bit windows)