Using VEP5 and a slave computer: getting static.


I recently have gotten my slave computer built, and I got Vienna Ensemble Pro installed all ready to go! Now before this, I have been using VEP to route everything on a single computer. Everything worked great! Now that I have it supplying samples from a second computer, I am getting this strange white noise and slight crackling. I am puzzled as to what is going on as I do not believe it is my hardware. I am using Cubase 8.5 and a Steinburg UR22 Audio Interface with my buffer size being stable anywhere from 128+. The buffer size from VEP is 256. I messed with the external clock setting and it seems to have made some change but the fuzz is still present. I am not breaking 20% cpu usage on my main computer or 55% on the slave.

Windows 10, CPU-Intel i7 6700k, MB-Asus z170 Deluxe, 32GB DDR4, Samsung 850 Evo 500GB (OS), 2x WD 1TB HD Raid 1 (Storage). Linksys AC1200+ Router.
Slave: Windows 10, CPU-Xeon 2680, MB-Asus x99 WS-E 3.1, 64GB DDR4, Samsung 850 Evo 500GB (OS), 2x Samsunge 850 Evo 1TB (Samples), WD 1TB HD (Storage).

Just a quick thought : i usually have static when i mismatch sample rates (44, 48.1).

Since I am using two computers, do I need to set up my ASIO through VST System link?

Have you tried upping the buffer setting in the VEP5 Server Interface (within Cubase)?
Also, your network need to be wired, generally.


I have upped the buffer size on the VEP5 Server interface, and on the Ur22 interface both to no effect.

If I put the buffer size to 4 in VEP, anything above 512 sounds sluggish. Anything with a VEP buffer size of 3 seems to be having all sorts of problems.I have even tried each value on the UR22 with a VEP value of 0,2,4.

On running everything on my master computer, 6700k, I was using a buffer size of 768 and a VEP of 2. I cannot even use that on my Xeon.

What are the pros in cons to having a lower ASIO buffer size yet a higher VEP buffer size multiplier, or vice versa?

Any other suggestions?

I don’t believe the buffer on the UR22 should have much effect - if everything else in Cubase on your master Comp is fine - since VEP does not interact with the interface, it just passes audio to Cubase.

The only other thing is to look at the preferences on the VEP instances on the slave machine and see how many Threads you have assigned.

Not looking at your sig, but if the only thing you are running is VEP on the slave, then you should set the Threads to equal total (Virtual) cores divided by “Number of Instances”.

Like . . 8 cores and two instances = 4 Threads per instance.
The Thread count is, by default, a global setting (I think) so if you set the cores on one instance it will be the same for the others.
You should also run as FEW instances as you can. Use all the MIDI inputs and output channels you need.
Like I have an Orch Metaframe that uses 1 instance for Woods and Horns and 1 for Perc and Strings.

Not sure what your issue is . . almost sound like some DEEP Network issue.
I have NEVER experienced Hash. Glitches, yes. But that’s different.

Hope this helps.


So some people asked to listen to examples of these clicks and pops; as I was exporting several files, I was unable to to replicate what I was hearing in both Cubase 8 and 8.5. If I hit play in Cubase, I would get the pops but not in the exported file. I then tried a transcription of Koussevitzky’s Bass concerto, which is thinner instrumentation and more delicate than some of the other stuff I have been working on. I still continued to get the pops and clicks in Cubase. Upon repeatedly listening to the exported audio files, I finally found a fuzzy pop! As I went back to figure out the exact second it happened, I could not find it. I then continued to play back the WAV files; I found that the pops and clicks do not always happen. When they do occur, they are not always in the same spots. I thought that maybe it was my speakers failing on me, but I just listened to everything with my headset and the random pops and clicks in my finished wav files and cubase continue to haunt me. It only seems to be happening when I am listening to audio files, not necessarily listening to sound from youtube or netflix. I am genuinely confused at this point.

Could it have something to do with the export bitrate being 32(float) and the project bit rate being 24?


Any any all WAV files which have the pops and clicks do not have them on the other computers, speaker(s) combinations that I have access to. The pops which occur in the WAV files are not as pronounced as when in the DAW.

It is definitely not the DAW, VEP, or the network connection. I was experiencing pops and clicks when listening to some Mahler through Youtube and a few sound cloud files.

It seems my UR22 died on me. I switched it out for a Scarlett 2i4 and it seems to be working fine.

With the problems I have been having, I decided to see if I am having any bottlenecks in the master computer and the slave computer. It seems like I am indeed having issues with my system. Although the new Audio interface has resolved the pops, I definitely need to see what I can do to streamline this system. Any suggestions as to how to tackle this?