Uwanted Periodic VSTi Sound Triggered Druing MIDI Playback

Hello All,
I have created a MIDI drum track that is played through Superior Drummer 2.
In this project I also have several audio tracks.

Whenever I play back the song with the MIDI Track record enabled, a periodic sound is triggered from Superior Drummer (it happens to be a cymbal crash), but there is no MIDI event shown in the MIDI Editor corresponding to this sound.

  • If I disable the record button in the Track List / Track Controls while viewing the main Project Window this periodic sound stops.
  • However, even after I disable the record enable button described above, if I then open the MIDI Editor and play back the song, then this periodic sound occurs again (unless I activate the Solo button in the MIDI Editor).

This is probably user error; can you help me figure out what is causing this unwanted/unidentified sound trigger to occur, and how to prevent it?

I am using Cubase Pro 8.10 on a PC.

Thank you for your help.
Scott

Hi Scott,

I expect, you are using “All MIDI Input” as the MIDI In of the track. I would recommend to change this, and switch thru all MIDI Inputs, you have available. This way, you can find, which MIDI device sends the data.

Are you using Mackie Controlor any other remote controller?

Thank you for your reply Martin.

I confirmed that all MIDI tracks do not have “All MIDI Input” as the MIDI In --> the problem still occurs.
I even changed the MIDI In to “Not Connected” --> the problem still occurs.

I use two MIDI devices:

  1. Steinberg CC121 controller.
  2. Nektar MIDI Keyboard.

However, I also restarted Cubase with these two MIDI devices turned OFF, but still this problem occurs.

Do you have any other idea that I should check?

Thank you,
Scott

Hi Scott,

This is tricky… Are you using any MIDI Inserts in the track? When the sound is here even if you set “Not Connected” as the MIDI In, then the MIDI signal has to come from Cubase internally.

I don’t know the Superior Drummer 2 very well. Isn’t it some internal pattern?

Btw: Could you update your Cubase to the latest version Cubase 8.0.20, please?

I have had this exact same problem and never solved it unfortunately. I always assumed I had a stray note from some input that I just could not find. In the end I remvoed tracks and recreated them

I can confirm this behaviour with Addictive Drums. It seems that when you click on the track in the inspector the active vsti occasionally picks up midi signals. I made sure there were not midi inputs active, bypassed any insert effects on the vsti channel to ensure that they weren’t passing midi to the track and the behaviour persisted. My solution was to click on another track in the inspector which sometimes fixed it or restart Cubase and behaviour would disappear. It is intermittant and I can’t reproduce the issue consistently but it does appear. My guess is that this is happening with other vstis but we can’t hear it as readily as say a stray cowbell in the middle of a phrase.

Hello again,
In case this will help someone experiencing this same issue, I wanted to let you know how I fixed this issue:
The cause of the unwanted triggering was the “Chord Track” that I have in the project. Muting the Chord Track stopped the unwanted triggering.

(I have not yet figured out how to keep the Chord Track un-muted without having it trigger the VSTi, but I believe some MIDI parameter setting in the Chord Track can probably solve this.)

Best regards,
Scott