v5 LAN connection error


Just tried a local test using v5.0.10.564 PRO

When I try to connect over the LAN - I get “Connection Error - local connection failed”

Studio win10 - performer MacOs (big sur!)

as soon as I switch the client over to a tethered phone it works fine.

Zero firewalling on the studio end.

Works fine here, did you try several times? Does it take a few seconds until the message appears? Then it really can’t connect, which is very likely to be an Operating system or installed feature problem.

yes - tried a few times on the LAN - restarted client/studio etc.

there is a several second delay then I get the error

If I switch the wifi on the performer over to a tethered phone (without changing anything else) it works fine (using ID login)

Means it just can’t connect; it waits for that amount of time, and then OS says “no” but no further explanation.
We didn’t touch the local connect code for several months now as it always worked and still works just fine (we use it every day). Pls check what you have installed or otherwise changed with your system. ID etc is a different path across the internet, local is not (sic). You may want to check router and other local (physical) connections.

I don’t normally use LAN connection - only for testing.

definitely no change - and it’s a local network so NO router/routing involved. No firewall and both computers can see each other fine (file sharing etc etc)

Either way, no big deal as I can test via tethered…but there’s definitely something broken in there.

Wow…now it fails here as well :frowning:
This is very likely due to the most recent Windows update which just got installed. Traced the code, both sides listen to each other but messages don’t get passed :frowning:
Will search and check what happened. It never ever failed on me before. Don’t I hate…

Maybe windows 20H2 but I’ve had some random problems with it before.

You probably don’t remember but a few months ago tested across 3 different clients on the LAN - 2 windows PCs and a Mac.

LAN failed on one of the windows PCs - ok on the mac and the other PC. Didn’t really have the time to debug further. At least when it’s fully broken it’s easier to track down…the glass is half full :slight_smile:

I’m still not convinced how useful the LAN function is or how much value it brings - If I can get a cable to somewhere else in the building I’d rather run some audio cables not use vst connect…maybe it should be part of the “lite” version so that people can use it to test without having to tether to a phone ?

…ghost in the machine…it works again. No idea, must have been something else, phew.
Try again, you never know. Will watch very closely.

For us, it’s invaluable for testing. We do test a lot via WAN with two distinct Network lines as well, but some tests require to stop and analyse a situation without the connection getting reset externally because of connection timeouts.
For the user, it’s a good way to test and learn how it works before connecting with a client.
Also long analog audio cables have significant quality loss. Sure, you might use other tools, or a digital cable, but if you have it already it might come in handy :slight_smile:

yes I only use it for testing so when it breaks I don’t mind :slight_smile: - there is something screwy there though !

still think this should be in the ‘free’ version just to allow testing. :smiley: