V8.0.30 - Disabled track recall problems

Hi,

Regarding the issue of disabled tracks not recalling their Input, Expression Map and QC setttings. I tried a simple project with one track and 8.0.30 seemed to have fixed the problem. So I turned to my main template and disabled a few tracks. They also were recalled correctly after the save->close project->open->enable operation. I then got over enthusiastic and disabled some more. Upon re-opening the project and enabling the tracks, the EM and QC settings were lost on all the previously disabled tracks.

As anyone else tested this please?

Thanks, Ian

Testing right now…I thought I was fixed, gonna try with more tracks

Thanks, I look forward to hearing if you see the same problem I am experiencing.

It may be that my project file is corrupt, or it may be that there is a particular sequence of events that cause the problem. I intend to investigate further tomorrow.

Cheers, Ian

I have tried disabling 20 tracks, and then almost 150 of my template. Saved and reopened. Activated them and the settings were there. Expression maps and midi in.

Haven´t tried QC yet

yep, this is working for me as well!! Yay

Working here as well, expression maps and midi inputs being recalled! Unfortunately I have to go through my 1500+ track template and select all midi inputs and reload the expression maps and then re-save the template for it to work, but at least it’s fixed…

Just got 8.0.30 installed and did some preliminary tests. On first go, it would appear the issue is now resolved. Disabling/re-enabling tracks saves the MIDI input and expression map - as does disabling tracks, closing project, re-opening project and re-enabling tracks.

Ian - are you able to reproduce your problem in detail so the rest of us can confirm? I’d like to know myself if this issue is finally resolved or only partially solved on the surface…

Thanks all for reporting your successes! I have tried again this morning and still have problems with my main template. It works, and then it doesn’t. Unfortunately when it forgets the settings, it is not just for one track, it forgets them all. It seems to remember the MIDI input, but not the ExMap or QC settings. All my tracks use ‘All MIDI Inputs’ though so it could just be selecting a default value.

I created a new project file from empty, added 100 or so tracks, and couldn’t get it to fail. So it seems there may well be a problem specific to my main template file. I could not see anything repeatable about when it would change from working to failing, but it happened several times.

I’m afraid I will have to leave testing for now, other things to do, but I will try and return to the problem as soon as I can.

Cheers, Ian

Thanks for checking. I also had just used a new empty project to test. But perhaps if I open my old template project I may have issues. I’ll find out before too long any how.

After hours of playing around with my template, I came to the conclusion that operation was random and my template file was corrupt. Having not seen any problems on a test with a new file I decided to start re-creating my template from scratch. I soon came across the problem, and have an sequence which fails consistently on my machine. It is so basic, that I wonder if my Cubase install is dodgy.

  1. Create a new empty project
  2. Add a single instrument track (Prologue for example), load an expression map and assign it to the track
  3. Disable the track
  4. Save the project and close it
  5. Open the project
  6. Add a second instrument track (Prologue again) and assign the expression map
  7. Disable the track
  8. Save the project and close it
  9. Open the project
  10. Enable track2 and the expression map link is OK (Optional step, does not affect the outcome)
  11. Enable track1 and the expression map link as gone

Would someone mind spending five minutes and testing this on their setup please?

Thanks in advance, Ian

An addendum to my previous post…

After running the sequence I described, and changing the MIDI input and QC settings, I found that they are being recalled correctly, just not the Expression Map. Unfortunately, out of the three, this is the one I would most want it to retain! Also, I trashed my Cubase settings and ran the test again with the same results.

Confirmed!

Tried your eleven step test, same thing here.
It’s the single most important thing that holds me back creating a new template since the Disable Track feature has been introduced.

Thanks for confirming that profezeus. Not for the first time, I find myself questioning Steinberg’s software release and validation credentials.

I can confirm it’s not working here either unfortunately. I opened my template that I had been re-saving and selecting “All Midi Inputs” on this morning and again, no midi input, no expression maps. So frustrating…

Would someone mind starting a thread in the Issues forum and link to this thread? Or maybe a mod can move this thread over to that forum.

Thanks all for your assistance with this matter. I have submitted a new thread to the Issue Reports section.

+1

That feature was the reason i upgraded (to avoid using VSL VE Pro) to C8 two month ago. It holds me back to actually use C8.

Please fix it. Thank you.

This is still not fixed in 8.5 !

This is happening for me on a brand new Cubase 8.5.15 installation (though I had Cubase 8 way back when). Brand new session / template that I’m creating. Re-enabled tracks cause the associated MIDI tracks to lose their routing.

https://www.steinberg.net/forums/viewtopic.php?f=231&t=85428