Value slurs and silences

Hello everyone,
I saw a post about the problem I’m trying to solve but I can’t find it.

I imported an xml file with two parts on the same staff for many instruments in order to make a new orchestration. To separate the condensed instruments, I created a new voice and selected the voice with the descending stems to switch it into the new voice.
This gives me two problems:

  • the first is that the note stems change direction when there is a slur of value. I can’t change this other than by choosing the engraving mode and clicking on the corresponding note and the “f” key, or by deselecting the season (u), changing the direction of the stem (f) and clicking again on the notes I want to link and then pressing “t”. This takes up an enormous amount of my time and I would have liked to have seen a simpler solution, if one existed.
  • the second problem is that when I toggle the voice with the descending stems, the rests no longer register automatically, so I have to select each note before the rests and then click on the “end voice” box.
    Finally, I have a major problem of slowness when I perform actions on even a few bars.
    I have to admit that I have a very large file (more than 50 separate voices). But I have a 3.7 GHz Intel Core i5 6-core iMac and 64 GB ram Ventura system.
    Sorry to have been a bit long and thank you in advance for your help.
    Capture d’écran 2023-05-26 à 11.34.51
    Capture d’écran 2023-05-26 à 11.45.52
    Capture d’écran 2023-05-26 à 11.47.02

I guess you have ended up with all of the stems having forced directions – try selecting everything with Ctrl+A/Command-A, then switching to Engrave mode (which may take a little while when everything is selected, so be patient) and then do Edit > Notations > Stems > Remove Forced Stems.

In general when importing MusicXML, I would recommend going to the MusicXML Import page of Preferences and turning off all of the checkboxes there before you import. That way, Dorico is free to notate everything the way it sees fit, rather than trying to preserve the appearance of all of the items in the MusicXML file, which is rarely what you want.


Hello Daniel
Thanks for your advice. I will remember to disable all checkboxes next time.
In fact I selected my whole file and tried to remove the forced stems but I waited two hours and I still have the multicolored wheel spinning… but the file is heavy; it’s almost 29 mn of orchestral music.
I’ve just updated Dorico 5 and hope it will make a difference.

If you want to send the project to me, I can see if I can do it any more quickly! But it will take a while to process the whole project note by note.

Couldn’t you import the file again, this time without the options? Might that be quicker?


Hi Janus,
I’ve thought about this possibility but I’ve already done a lot of work on the imported file and I’m afraid of losing more time.

If you re-imported the file into a separate file or flow, could you copy sections or instrument parts that worked into sections or instrument parts that did not which you have not already edited?

1 Like

Hi Derrek,
I agree this may be the solution. But I think I’ll re-import the file in an other one because the one on which I work is already very heavy (50 separate parts and 29 mn of music…)