Vari-Audio crash while "analyzing audio" 6.0.2

opened a 6-7mb file -> vari-audio and cubase 6.0.2 freezed at “analyzing audio”.
two files are corrupted after then. Not really funny but helpful for some decissions and unpleasant moments. :confused: :unamused:

…looking forward to the next official release. :arrow_right:

Not enough ram perhaps? Vari audio is in ram, it cant be streamed.

I had this problem too on a small project on Win7 32bits.

I tried to bounce the problematic part some times. And then, on some trials later it worked…

good point Hippo, i have 8gb, that should be anough but i am working with cubase 32bit on 64bit plattform.
there´s still the 2gb limit i guess but i can not belief that cubase goes into a crash if the ram limit is reached… i need to check this with the task manager.
Many other programms have an intern ram limit option that you can adjust. A similar thing could help finding out the cause of the crashs but this is all speculation. I remember if you go into the files very often and do a lot of vari-audio things on longer takes there have been crashes. If you start and close a project very often one after another, the project becomes instabile sometimes too. So it might be an unstable read/writing or analyzing thing.

I have the exact same problem.

I don’t think it’s a RAM issue, as operations fail that worked under 6.0. And even if it were due to a lack of memory, I would expect an message, not a hang-up.

I think it’s a… [drumroll] …bug!

Some more testing:

I can re-create the problem by creating an empty project (44.1kHz) and importing the AIFF file at http://chilp.it/ab04ab (created from a Garageband file I got from a vocalist; you’ll see why I need VariAudio to work). Sample size and mono vs. stereo made no difference.

When turning on Pitch & Warp, the process of analyzing gets stuck (not crash), with Cubase continuing to do something on one CPU core for hours, if I let it. Cubase’ window is frozen and I have to kill it.

RAM use is nominal when it hangs, a mere 10MB above what Cubase uses with no project open (several GB of physical RAM are unused and could be allocated, but aren’t).

On some files it gets stuck at 97% or 98% of the initial pass, but on this one it got always stuck on 44% of the second pass, but never anywhere else.

So, I guessed that it might be specific to the material I use, so I applied started chopping the file recursively in half (like so: http://mines.lumpylumpy.com/Electronics/Computers/Software/Cpp/Algorithms/Find/BinaryChop.php)

After the first chop, which wasn’t exactly in the middle but close, analysis of the first half got stuck at 77%.

Unfortunately, after chopping the first half into two parts (each approx. a quarter of the original file), both files could be analyzed. Not what I had expected, but there you go.

I spoke to support (helping them fix their stuff at €1 per minute!), who are claiming that they cannot reproduce this problem and that “we are determining if this is a bug”. Feh!

On a side note: who came up with the idea to disallow *.aif file as attachments in this forum? That seems daft.

Hi @ all,

after downloading the Audiofile "BYTHEWAYFINAL2-2"and trying to Pitch & Warp I can confirm, that there is an issue with this audiofile in Cubase 6.0.2.291.

:arrow_right: I have created a new Bug Report, No.: 28742

Thank you, Marcus! I appreciate it.

P.S. I removed the file. If anyone needs it again, let me know by PM.

I have also had this issue, precisely as described, always stuck halfway on pass two. So far this has happened only to really long files, like hour long concerts, other shorter files recorded with the same hardware and settings work fine.

Thanks for acknowledging, Marcus!

/A

I have this problem in Cubase 5.5.

I don’t expect a bug fix, but does anyone have a workaround? Can I somehow run variaudio on part of a file?