Variation Groups (Round Robin and Random) doesn't work

I read and strictly followed the manual of HALion 4 / 5 / 6 regarding how to make round robin samples, but it doesn’t work in HALion 6 – all round robin groups still articulate together in tutti, making heavy machine gun sounds.

Here’s what I configured in my HALion patch:

  • DIVISI LAYER A (Edit -> Sound -> Variation Groups -> Enable -> 1 Random, 2 Random, 3 Random, 4 Random)
    – RR Layer 1 (Edit -> Zone -> Voice Control -> Variation Group 1)
    – RR Layer 2 (Edit -> Zone -> Voice Control -> Variation Group 2)
    – RR Layer 3 (Edit -> Zone -> Voice Control -> Variation Group 3)
    – RR Layer 4 (Edit -> Zone -> Voice Control -> Variation Group 4)
  • DIVISI LAYER B (Edit -> Sound -> Variation Groups -> Enable -> 1 Random, 2 Random, 3 Random, 4 Random)
    – RR Layer 1 (Edit -> Zone -> Voice Control -> Variation Group 1)
    – RR Layer 2 (Edit -> Zone -> Voice Control -> Variation Group 2)
    – RR Layer 3 (Edit -> Zone -> Voice Control -> Variation Group 3)
    – RR Layer 4 (Edit -> Zone -> Voice Control -> Variation Group 4)

Under this configuration I am expecting that every time I press the same key it sounds different timber. However it sounds like tutting the all RR samples. Tested in HALion 6.0.1.72 on Windows 10 Pro x64 1709 and macOS 10.13.3;

I have no idea whether this happens with HALion 5.

I just feel bad now. I use HALion just for making some patches usable in Steinberg Dorico, and now the this issue blocked my way.

You need to set all layers to the same variation group.

Alternatively if your samples are in layers and you want to alternate the whole layers then use the Layer Alternate midi module in which case you don’t need the variation groups, just set up the midi module.

Thank you for your suggestion. The Layer Alternate works well to me. :slight_smile: