VariAudio does analysis then nothing else.

Hi!
I’ve searched the forum and couldn’t find exactly what I was looking for.
I have a very simple project in which I am trying to use variaudio on one track yet when I call it up I get a window that says “Analyzing” and “Step 1 of 2”, it finishes “Analyzing audio” then nothing happens and everything looks as if I had never clicked on Pitch and Warp.
I’ve updated cubase many times but I’ve had this problem since Cubase 5. On some projects it works on others nothing happens.

Any help would be greatly appreciated. Thank you!

Info: Project is in 96kHz, 24 bits. This has happend to me at 44.1 too.

Try zooming vertically after analyse.

Thank you for the reply but no that didn’t work and the range is very limited to have actually missed that.
Also, now it works. The only difference before was computer load at that moment was high due to some other program that was encoding video. Now I get the second step Detecting notes.

I really hope I was wrong about this but I get very inconsistent variaudio functionality.

Do you think encoding video and running cubase simultaneously is wise?

Do you regularly run other programs while using Cubase?

No, actually I was just mentioning it because it was the only difference. Besides, Cubase says nothing when it fails and this has happened for years with or without cpu load. VTS performance was perfectly normal on this six core cpu.

I can confirm it is not working again. I have nothing running beside cubase 6.5.3 with a few Kontakt 5 instances and some small synths on a very fast 6 core cpu

I’ve attached an image of all that I see when I click Pitch & Warp just in case. As I mentioned, sometimes it works, sometimes it doesn’t, it did a few hours ago, it didn’t last night and doesn’t work now. It always goes from click, message, nothing happened.
Untitled-1.png

Does it also happen with Cubase 64-bits?

Interesting question but I cannot try out right now. I did not install the 64 bit Cubase because I am still migrating some old VSTs and VST bridge wasn’t playing nice. I’ll finish something and install it again in a few days. :smiley:

Hi Irregular.

I see an almost similar behaviour in v6.5.4, but not quite.
When I open an audiotrack in VariAudio mode, the audio is analyzed. As far as I can see both steps are executed, but step 2 is performed so quickly it is almost invisible. Apart from this nothing more happens. I think this is the way it is supposed to work.

To actually change the pitch of the audio you have to select all or some of the segments and then move the Quantize Pitch and Straighten Pitch sliders.

You can reanalyze the audio by selecting the Reset-Reanalyze Audio drop-down function in the VariAudio panel. If you look closely you may be able to see Step 2 of the analyze function is performed very fast.

I hope I am not confusing the matters.

Kind regards
Ib-Michael

@imm
Thank you but that is not the solution. I tried this with a longer track too and when it worked the second step took longer and wasn’t instantaneous but it did work then. Now it is not working again even if I reset it many times.
I’ve always wanted for cubase to have a better log of what is happening in the background.

I do have the same problem with Cubase 5:
After starting the VariAudio analysis the progress bar moves slowly up to about 70% then breaks up and nothing has been analysed. No outcome at all.
VariAudio has worked after installation of Cubase about a year ago (Win7 64 bit) but now it doesn’t work any more.
I deinstalled and installed Cubase 5 several times and also deleted the personal settings (AppData) but this did make VariAudio work again.
Does anybody have any suggestion how to fix this problem?