Velocity editing issue

When editing note velocities in the piano roll editor using the vertical velocity bars no audio change occurs. Yet using the histogram (a brilliant tool) does successfully change the velocities. Is this expected behaviour or a bug?

Secondly, after using the piano roll editor it often gets stuck on the last instrument I was working on. For example, if I was working on a kick drum, then close it and open up the piano roll for another instrument it still shows the kick drum. Closing and opening the app often clears it but at some point in the work it happens again.

I have an iPad Pro 10.5 (2017) running the latest iPADOS.

Thanks for an amazing app!
Andrew

You should certainly find that edits to the selected velocity bar take effect – they do for me. However, we do still plan to make some further changes to the way the velocity editor works with regards to the selection in future.

With regard to the Key Editor getting stuck on the wrong instrument, I’ve not seen that, but does disengaging and then re-engaging the linked mode button in the Key Editor toolbar help?

Thanks - I’ll check these out next time I’m at the iPad.

One further question:

Is there the facility on the iPad version to have a player only sounding on either the first or second time of a repeat section?

No, that’s not a feature that Dorico has at present, I’m afraid, either on desktop or on iPad, but it is planned.

Thank you

the key editor is also my main working window when entering notes in dorico for iPad (with the Apple Pencil).
I have also observed the problem you describe.
My workaround:
Don’t click immediately on the velocity bars but press the “Expression and CC” button on the left before. Then make the required changes and finally press the button again. This way the velocity values can be changed without errors.

Thank you - using the link button worked :+1:

Thank you - that worked :+1:

Sorry to revisit the Velocity Editing issue again, but I am still finding that editing the velocity bars has no effect (while the histogram does work.)

I created a simple Piano part with just a C major scale running up and down using just the default instrument to test it but still no joy. Am I missing a setting or something?

@spassbeisaite - unfortunately the workaround isn’t now working for me - unless I have misunderstood the steps.

I am on a 2017 iPad Pro 10.5 running iPadOS 15.3.1

Ok - here’s a strange thing. I selected the draw tool and edited a couple of velocity bars - and it worked, and then it worked just using the selection tool as expected. Oh well - we get there in the end.

Thanks for all the support.

BTW - I’ve just discovered the transform tool - excellent :+1:

My workflow:

  1. open Key Editor
  2. Click on Expression and CC
  3. click on the chain icon
    ATTENTION: Do not select the pencil but the arrow!
  4. select the desired note in the score (you can also do this with a bar symbol in the Key Editor)
  5. now the bar for changing the volume should be displayed in black. Now make the change.
    At the end, switch off Expression and CC again.

This method works, but it is inconvenient. Also, individual notes within a chord cannot be selected. Unfortunately, the whole chord is always selected.

Many thanks - I will check this out next time I’m at the iPad.

Thank you for outlining those steps so clearly - following them gave me success.

I was also able to independently adjust individual chord notes by selecting them in the score (by judicious zooming in) - and then adjusting their highlighted velocity bar in the key editor.

Incidentally, Dorico for iPad 2.2 also includes a numeric Velocity property that you can edit in the Properties panel; this will make its way into the next desktop update too.

1 Like

Thank you - I hadn’t realised that. Most useful for fine tuning the individual velocities.