Velocity Issue with Yamaha KX88

Hello, all
I own KX88 and notice that softest velocity I can get out of this keyboard is 15.
Is there any way I can set velocity 15-127 to 1-127?
I’ve researched a little with midi transformer plugin and it just confuses me.

Does anyone know how to deal with this issue?

Thank you in advance.

I have a Yamaha KX61.

What is your velocity curve set to (on the KX88)?

I was looking into velocity setting in my keyboard, reading manuals and stuff, but I could not find a way to change the velocity curve setting. If you know how to do it with kx series, please enlighten me!

:blush: I made a mistake.
I mistook the KX88 for the KX8 (the KX8 being in the same generation as the KX61).
Looking at the KX88, it’s a completely different unit (previous generation, I believe) than the KX61.

I took a look through the manual for the KX88 as well and couldn’t find anything about changing the velocity curve.
So I’m barking up the wrong tree there.
However, the MIDI implementation on the KX88 says it can transmit velocities values from 1-127.

Sorry I can’t be of more help.

Thank you anyways for the replies, yeah it is old keyboard from the 80’s. I found that other owners have same issue too and read that some people deal with this using midi transformer plugin. I just don’t know how to work it. I think some other keyboards also have similar issues having there softest velocity at certain value. It might be a mechanical issue.

Hi, Brandon

Using the Input Transformer is not that complicated. Please look at an example here (6th post of mine) :

http://www.kvraudio.com/forum/viewtopic.php?t=349424&highlight=

For your precise problem I would substract 15 and multiply by 1.13 in this example. It will give you something like a 0-126 range. This, without forgetting to ajust the different parameters in the first pane for a keyboard usage, instead of a CC pedal.

Hope this will help.

Thank you so much cubic 13! I will try that.

Hey cubic 13, I think this will be my solution, problem is I’m not sure what to choose for all the parameters.
This was what I was trying and was not able to get it working.

Transform on the bottom

1st Pane

1st line :

  • ‘Filter traget’ : ‘Type is’
  • ‘Condition’ : ‘Equal’
  • ‘Parameter’ : ‘Note’ (This gave me velocity in the 2nd line filter target)
    ‘And’ for the ‘Bool’ column

2nd line :

  • ‘Filter target’ : ‘Velocity’
  • ‘Condition’ : ‘Equal’
  • ‘Parameter’ : ‘0’ (I wasn’t sure)

2nd Pane

1st line :

  • ‘Action traget’ : ‘Value 2’ (I wasn’t sure)
  • ‘Operation’ : ‘Substract’
  • ‘Parameter 1’ : 16

2nd line :

  • ‘Action traget’ : ‘Value 2’
  • ‘Operation’ : ‘Multiply by’
  • ‘parameter 1’ : ‘1.13’

Can you please help me to choose the right options?
Thank you so much for your help.

I would rather set the whole thing as following :

First pane
Line 1 :
Filter target : ‘Type is’
Condition : ‘Equal’
parameter 1 : ‘Note’
Bool : ‘And’

Line 2 :
Filter target : ‘Velocity’
Condition : ‘Inside range’
parameter 1 : ‘15’
parameter 2 : ‘127’

Second pane
Line 1 :
Action target : ‘Value3’ (If I remember well, it’s the third value of the MIDI ‘notes on’ messages that holds the velocity amount of each note)
Operation : ‘Substract’
parameter 1 : 15

Line 2 :
Action target : ‘Value3’
Operation : ‘Multiply by’
Parameter 1 : 1.13

Don’t forget to check that the module where you set all this is active : there is a rather dimmed button at the left of each of them which need to be activated for the one you have chosen. It can be helpful to save your settings as a preset, also.

Money! Cubic13
Thank you so much it worked!
Only thing was I had to set action target to “Value 2” instead of 3.
Been a great help!

Thank you so much again!