Version 2.2.10 GUI performance changed?

I purchased Dorico 2.2.01 a little over a week ago and have been enjoying discovering Steinberg’s take on the world of music scoring - lotsa fun I must say!

I few days ago I upgraded to version and one thing I noticed in this latest version is it seems to be ‘working harder’ than the previous version.

Sometimes the playhead freezes for maybe 5 seconds (thereabouts) and cpu usage increases somewhat (15%) as indicated in Task Manager (Win 10). Music playback continues uninterrupted (expected behaviour) but Dorico seems to be working harder now after the update.
The freezing occurs other times too (e.g. no music playing, just editing etc in Write or Engrave mode).

Is this expected behaviour (I suspect it might be but thought I’d ask anyway)?

Some system info:
Win 10, CPU i7-3930K, RAM 32G, All VST data housed on SATA SSD, blah:)

I couldn’t say for sure, but I’ve noticed also what I think you’re describing. I’m almost positive it’s the autosave feature, so I’ll gladly take the occasional chug in exchange for the peace of mind.

It certainly could be auto-save, yes. Depending on the size of your project, auto-save might take 2-3 seconds even on a machine with SSDs: the more VST data there is in the project, the more data has to be written to disk, and the act of saving itself is reasonably CPU intensive for the audio engine. If this bothers you, you can of course increase the auto-save interval from the default 5 minutes, or disable it altogether.

I noticed that too, this week : sometimes, the keyboard key I’ve stroke would not change anything in my score. Of course, it’s auto-save.

The stutter that autosave requires is the principal reason I have never used autosave but instead made frequent saves and manual backups a habit.

Is the mixer showing? We think there could be some interaction between it and autosave that causes a slowdown

Obviously can’t speak for the others, but in my case, the mixer is not showing.

If it’s relevant, the slowdown I’m getting for autosave seems to be equivalent in length and overall effect to a normal save. In this case, it’s about 1-3 seconds, but the score I’m working on is pretty sizable (full orchestra, multiple additional full score layouts for later part condensing, etc.).

Thanks Daniel, I’m going to spend some time today investigating further. I suspect I’ll probably disable auto save and revert to a more obsessive compulsive kind of “Control + S” routine.

Actually, that reminds me - when saving a project (on Windows) the convention is for the cursor to be temporarily changed into an hourglass for the duration of the save. Ah, like sands through the hourglass, so are the days of our lives. I’m sure you’ll get this sorted soon enough … :slight_smile:

By the way, over the weekend I fired up Cubase 8.5 and dumped the contents of the Dorico project (exported midi file). Yep, Cubase working fine, no performance degradation whatsoever, all good there.

PS PaulWalmsley - The mixer visibility didn’t seem to make any discernible difference to the ‘slow down’ issue.

I’ll fire up Dorico later this afternoon and continue to investigate…

I’d just like to chime in here, since 2.2.10 I’ve been experiencing noticeable lags at various seemingly random moments. Sometimes selecting a note, sometimes hitting Esc to exit out of something, playing back, etc.

I haven’t yet turned off autosave, because it’s set for every 5 minutes, and the lag happens much more frequently than that.

Again, I haven’t been able to pin down any pattern. The mixer is not showing. Not using a MIDI keyboard or any external devices. Stock sounds, engine, etc.

This is for a symphony band score, but just starting, so not many instruments playing, etc.

Plus, I got this laptop specifically to handle Dorico, and I think the specs are fine:

Windows 10
Core i7-8565 (4 cores)
16 G RAM


p.s. It’s a little disconcerting when I save and “Not Responding” comes up! Not every time, but often enough!