Vertical justification of staffs

Good morning,
Excuse-me if I come back with this problem, but I cannot find how to resolve this problem. In the attached file, there’s plenty of space for the next staff to be inserted at the bottom of the page, yet this is not what Dorico does. I can’t even do it manually.
Ruggiero Trofeo Canzon a 8 2 orgues test.dorico (829.6 KB)
Thank you for your help.

Try this interesting guide by @benwiggy:
Vertical Justification settings.pdf

1 Like

Open Layout Options.
In the Vertical Spacing category, set the Inter-system gap to a lower value.
Probably between 7 and 8 spaces should be sufficient. It is currently set to 12 spaces.

Thank you, but that dont solve the first page’s problem.
Ruggiero Trofeo Canzon a 8 2 orgues test 2.dorico (984.7 KB)


Best regards.

One easy way to fix this is to slightly drag the top of the music frame down making it smaller.

This could be done on the First page template to avoid a page override.

I understand, but my question is: why the first staff of the second page (bars 28 to 35) is not displayed at the bottom of the first page, while there’s plenty of space for that?

It depends a bit on how that extra space was made: if you moved systems up in Engrave mode using the Staff Spacing tool, that won’t cause Dorico to recalculate the casting off; that tool is for adjusting the staves/systems that are already on the page.

Dorico uses the height of staves and your vertical spacing settings to determine how much music fits on a page. Sometimes, that calculation isn’t perfect and one too many or too few systems get put onto a page.

You can help Dorico get closer to the right result by settings your vertical spacing settings as appropriately as possible. Generally, this means reducing the first set of gaps (because Dorico will never let staves get closer than this, but will always add on extra space as needed for high/low notes, dynamics etc etc).

See also:

Thank you very much. That what the answer.
I reduced the space between staves till 2 spaces. The first page was completed like wished. Than, manually, I gave more space to the staves of the latest page. It looks fine.

If you want to spread staves out, you can do easier things like resize the music frame, increase the inter-system gap, etc. Sometimes it takes a few attempts at adjusting settings to find the right balance for any particular project.

Remember that manual staff spacing overrides can get lost if the page number changes.

Another way I thought of that has worked for me is to tweak the Space Size for a layout. Sometimes it is worth changing this value to see what effect it has on casting off and vertical layout. That’s one of the first things I’ll try.

You’re right. But in this case, I didn’t find other solution (I’m a Dorico beginner).
The only way to display 4 systems on the first page was to reduce the inter-system gap to 2. As a result, the last page, which didn’t have enough systems to be justified, had a very small gap between his systems.

I did it also first.

When adjusting the staff size, it’s worth keeping performance material requirements in mind – eg recommended minimum sizes for parts, vocal scores, conductor scores etc.

Feel free to pose the question “How might I achieve good, balanced spacing in this project?” and see what the generous and experienced users of this forum suggest :slight_smile:

1 Like

I find Dorico does this quite often, especially on the first page of a flow, with the title, etc. If you use “Make into Frame” to force the system onto that page, you may find it is still not 100% full. For me sometimes that is the only solution.