Vertical spacing error

What goes wrong here? The music will still change so don’t want to manually override positioning in engrave mode yet.

There is no ‘wait for next frame break’ and I just adjusted the inter system gap from 10 to 8 spaces. This is Dorico 3.0.10.

Thank you in advance!


spacing (literally).png

[4. Post a project, not a picture
If you are having a problem with Dorico, the fastest way to get the help you need is to post the project, or a part of it, and not to post a screenshot. If you post a picture, you will almost certainly find that the first person to respond to your thread asks you to post the project. You may be concerned that the musical content of your project will be judged, or stolen. While we cannot guarantee that this will not happen, because of the supportive nature of the forum, this is vanishingly unlikely. There may be copyright or confidentiality restrictions that prevent you from posting the whole project. That’s fine! It’s always better in any case to cut the project down to a smaller size to attach it, particularly because there is a 2MB file size limit on attachments.

To cut down your project, first do File > Save As to save your project under a new name, to avoid making unwanted changes to your working project. If the project contains multiple flows, delete all flows except for the one that exhibits the problem. If the project contains multiple players, delete all players except for the one that exhibits the problem. If the problem is isolated to a particular bar or passage, then use the Shift+B popover to remove all other bars (e.g. select a note or rest in the bar after the problem passage, type Shift+B and enter a huge number like 9999 to delete all of the remaining bars in the flow).

Once you have cut down the project to the minimum scope that reproduces the problem, in Play mode choose Play > Playback Template and reapply the default playback template, or choose Silence. This dramatically reduces the file size of the project after you have deleted most of its musical material, because it removes the saved audio engine state.

Finally, zip the Dorico project up into a zip archive, and attach it to your post.

If you want to add a picture as well (perhaps annotated to show where the problem exists), then by all means do so. But if your problem relates to a specific situation you’re experiencing in your project, you are guaranteed to get a more helpful answer more quickly when you include a suitable project file to reproduce the problem.](https://www.steinberg.net/forums/viewtopic.php?f=246&t=155802)

I cannot upload (a part of) this project on a public forum. I thought this might be expected behaviour in certain circumstances that I can circumvent in a known way? With still shrinking the default system gap, that is. :slight_smile:

(I remember to see many screenshots like this on this forum, but I could’nt find one when I searched this morning.)

There are various things that come up now and again, but there’s nowhere enough context shown in that screenshot to be able to give you a definitive answer.

After playing with the settings for some time, I think I understand how Dorico comes to this result: It doesn’t take system objects like tempo text and rehearsal marks into account before deciding how many systems fit on the page. It decides, based on the space size and inter system gap, that 11 systems should fit on the page, and if that’s not the case, it doesn’t move some systems to the next page.

I found out a very elegant solution: I deleted all rehearsal marks. They weren’t really needed anyway and now everything fits well on every page.

You could also have inserted a frame break manually at the end of the 10th system, just to check if it suited you?

Thank you for the suggestion, Marc! I will eventually do that. Since the music will probably still change, I’m currently trying to avoid hard breaks, because then I have to constantly update those breaks throughout the score when I add or remove bars :slight_smile:

This is a wise point of view. Keep the breaks for the end of the job :wink:

And working in Galley view until then should at least keep staves from overlapping.