Very bad performance in C11 / Win 10 from multi-processing not balancing the load correctly

Hello,

i’m pro user, running cubase 11 on Win 10, 5 days a week.
i now my way around the usual cubase / windows optimisation & pref settings.

my new ( january 2021 ) studio machine got Windows 10 & intel 18 cores 10980 XE ( 3XS audio workstation )
intel speed step, turbo etc all disabled.
CPU running overclocked @ 4.5GHz, big cooling, low temp.

Converters = RME via thunderbolt PCIe Card

typicaly this is what happen :
i got a sound design session today, only wave files & processing plugins ( even not on all tracks )
it is a very light-load session compared to my usual,
and i got audio clicks ( and asio meter in the red ) with only 13 / 15% cpu use AND latency @ max ( buffer = 1024 )
because…
Core 0 is maxed out :confused:
( and a majority of my 36 cores are no used at all in this session )
And this even

i didn’t encounter this on my previous machine which was cubase 10.5 / WIN 8.1.

the maxing out of 1 core compromising the whole system performance is quite frustrating…
especially with the machine i have.

is there any thing i can try to avoid cubase from using Core 0 which seems to be used by windows & all system services ?
Or any other workaround ?

NB : my machine isn’t connected to internet, so WIN 10 didn’t had any update since march 2021

1 Like

I would suspect you have some latency issues with a driver. did you try running LatencyMon ?

thanks for the answer @glennloopez !

without any audio processing going on the computer in the green every where,
( IE, this is a new computer from this year, fresh windows install, used only for music,
optimised workstation for audio from 3xs )

RME converters have lastest firmware and corresponding latest drivers

if i run Latency mon while this problematic session is running, results are not good.
i can post them
but they only show what i know : in the “per CPU data”, only CPU 0 have bad data, the rest of them are OK…
and there are 35 more cpu core to spread the load :sweat_smile:

You need to look at what drivers have high DPC counts etc and then try to identify which component uses those drivers. Just because you have new hardware does not = flawless performance. Low latency is not automatic from a powerful CPU.

I had some problems with the asio meter spiking up on a regular basis, I then downgraded the intel networking card driver to a version from 2015 - all my problems were gone. often a quick way to troubleshoot is to disable components like Bluetooth, wifi, etc in Device Manager. If you have to dig deeper there might be BIOS upgrades and tweaks involved to make the system perform optimal.

You can look at my computer specs and I have an RME card too. I have very stable low latency at 3.7771 ms in Cubase and I am not even close to problems with 7-8 VSTi’s and a bunch of vst effects for mixing. In the main LatnecyMon window my current measured interrupt to process latency is never higher than 83 - mostly it moves from 11 to 36. and my buffer size is 128 on the RME drivers.

and if you have really new hardware you even might be unlucky and have to wait for RME or chipset drivers etc to be optimized. Sometimes I read Cubase struggled with the absolutely latest tech, I am not sure if this Intel CPU is brand new or what

1 Like

@glennloopez
Again thanks, i’ll take a look closer :wink:

do you run LatMon with C11 running or without ?
How did you spotted the culprit ? (network card driver )

no need to run Cubase, get your latency under control, and then go from there.

the best way to investigate imo is to start unplugging stuff, then disable stuff in the device manager

if nothing gives results try older drivers (or newer), but try to be systematic and do 1 change between every check with LatencyMon. It is can be very hard to work out these things so good luck

1 Like

I didn’t had time to check latency in depth today

analysis pointing to Wdf01000.sys causing highest ISR count
and my highest execution time for a driver is 0.8 ms for NToskml.exe ( NT kernel )…
really nothing obvious

but here’s my fix for the moment :
overrided the steinberg power plan to high performance with everything at max / never sleep.

AND
As all process where directed to core 0, and all cores where poorly used ( only by cubase )
i directed ( with affinity setting ) all audio process ( Cubase & bridged plugins ) to ALL cores but core 0 and it greatly helped the situation :wink:

i now have core 0 more around 80 / 90% usage instead of 100% before,
no more audio hickups

NB : my usual template is 200+ tracks ( VSL, kontakt libraries, a dozen vst synth, some FX buss with plugins )

in fact it is the same here beetween 15 and 60 / 80 ( sometimes ) this morning before new setting where applied

that is good results. should be possible to run rather big projects on low latency buffer.

if you run into problems with those low scores it’s very strange. Did you get “system not able to handre real time audio” results when you run Cubase while running LatencyMon?

Try sticking to VST2 plugins and Jbridge eveyone of them and put them all into performance mode in the Jbridge settings. This has made a HUGE difference to my cubase experince, almost no crashes and HUGE cpu reductions in projects. Some VST2 plugs don’t like being bridged so you may have to use those ones in “seperate gui” mode in the jbridge settings or don’t bridge them at all. Tone2 plugs for example just don’t like it

If you use any Acustica plugs though, this is a must do too. Jbridge distributes across the cores waaaaay more efficiently and you get the added bonus of crash protection for each VST.

Hope you work it out fella,
Best

1 Like

@Bobby_L_039_Avenir thanks for those infos :wink:

I only bridge old 32 bits plugin that doesn’t exist in 64 ( or that i don’t want to pay upgrade for ) - usually not more than 10 / 20 each session.

do you say that you bridge new 64 bits plugins ?
I’ll look into performance mode for the ones i already have bridged

@glennloopez
yes if ( for exemple right now ) i have a session where i have an average CPU use @ 15%,
but one core at 100%, so asio meter at 100% and audio clicking.
if i run LatencyMon while cubase is running like this, the results look ugly.

SO…

With no program running,
CPU 0 is @ between 0 & 1%
Average : 0 & 1%
all cores are beetween 0 & 1%

When loading Cubase 11 ( no project loaded ) :
CPU 0 is @ 50%
Average : 4%
all cores are beetween 0 & 10%

As soon as i load a project with a few VSTs and plugins or my basic template,
CPU 0 goes beetween 80 & 90% and then become the limiting factor of the processing power…

Doe those readings seems normal to you ?

Sorry only just seen this.

Yes, I bridge EVERYTHING, makes Cubase super stable and reduces cpu with performance mode turned on for each plugin. Run a test project for yourself and see before and after performance mode.

Some plugs don’t like being bridged though, (think i said this before) NI plugs for example but they’re super stable anyway, TONE2 plugs too, just don’t like it. Melda, Waves and Fabfilter along with a few others i use VST3 and no bridge because they’re very stable. Everything else i go VST2 and Jbridge it.
You just have to try it as you go, if you get a crash, Jbridge the plug that caused the crash and go again.
Honestly though i recommend just bridging everything x64 that you use for mixing and keep it super simple when producing using as much stock and stable VST3 stuff as you can. Low latency and less crashes this way

Jbridge my friend, Jbridge, trust me. Bridge those very same plugins and put them all in performance mode, you’'ll see cpu drop to almost half